systray specification...

Aaron J. Seigo aseigo at
Fri Feb 3 16:19:31 EET 2006

On Friday 03 February 2006 03:32, Carsten Haitzler wrote:
> OK - for now i've dropped the menu stuff. i've attached a much mroe
> detailed description of spec additions in the new_systray.txt. please read
> it over and throw in suggestions on improvements. we should still discuss
> the way of delivering icons i believe as there is no consensus yet. i
> personally stand on the side of "stick clear of requiring extra extansions
> to define the icons". (so re-use existing properties).

one of the nice things is we get multiple icons sizes for the tray along the 
way. we may wish to recommend 16, 22 and 32px icons be provided for all 
systray entries as that will encourage developers to provide enough variety 
that the icons won't look like crap due to being scaled.

instead of using _NET_WM_ICON_NAME for the tooltip/popup text, could we 
perhaps use _NET_WM_VISIBLE_NAME instead for clarity's sake? i think having 
"SYSTEM_TRAY_ICON_NAME" being a name of an icon and "ICON_NAME" being text 
shown for the icon to be more than a little confusing, and were i reading it 
for the first time as an outsider i'd think "boy, they sure have trouble 
naming things clearly." ;)

as for _NET_WM_NAME, i'm not sure if its enough for accessibility needs the 
way it's written: "This property should be used to identify the application 
name that owns this tray icon so it is easy to know where it came from." this 
may be interesting for systray implementations to use to connect the tray 
item with, say, taskbar entries .... but we probably want something more than 
"amarok", "kmail", "klaptopdaemon", etc... for screenreaders. if this is 
combined with the WM_ICON_NAME atom we'd get things like: "klaptopdaemon: 25% 
charged". we want something more like: "laptop battery monitor: 25% charged". 
while we could use NET_WM_NAME for this, we then lose the nice app<->tray 
entry mapping that would be useful elsewhere. 

i'm on the fence as to whether we should use yet another atom here or rejig 
the definition of one of the ones already used in your draft spec here. but 
then, it's only 07:20 here so i don't expect non-fuzzy thinking yet ;)
Aaron J. Seigo
GPG Fingerprint: 8B8B 2209 0C6F 7C47 B1EA  EE75 D6B7 2EB1 A7F1 DB43

Full time KDE developer sponsored by Trolltech (
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : 

More information about the xdg mailing list