David Zeuthen david at
Thu Mar 22 12:46:53 PDT 2007

On Thu, 2007-03-22 at 19:36 +0000, Richard Hughes wrote:
> Sure, GetLowPowerMode sucks as a name. GetPreferPowerSavings isn't much
> better tho :-)
> What about:
> GetPowersaveStatus
> GetPowerModePreference
> GetUseLowPower
> GetSavePowerPreference

Don't ask me; I totally suck at naming! Though I can, and do, blame
Havoc for the name HAL :-). With this disclaimer in mind I'd still go
for GetPreferPowerSavings() but at the same time I'm not attached to the
API name.

> Heh. I'll add it back to the UI when we get some common interfaces that
> things will actually use. ;-)

I'd just add it right away and wait for people to file bugs because of
the fact that certain apps don't use it. But that's just me ;-)

> > (Justification: suppose Totem/gstreamer used this, which I think we
> > want, and that it chose the video decoder accordingly; e.g. if
> > GetLowPowerMode()->TRUE the video quality is superb but makes my CPU run
> > at 1.8GHz. If ->FALSE then the video quality would be worse but in
> > return the CPU would run at 1.2GHz and I would get 30 minutes more
> > runtime; you know so I could actually finish watching the damn movie.
> > Morale: I, as an user, really don't want g-p-m to make this decision;
> > for me, and I guess, lots of other people it's a real user preference.
> > To me at least.)
> Well, this is a implementation detail of the session service, rather
> than an API constraint. I agree the name sucks tho.

Yup, it is an implementation detail private to g-p-m, kpowersave and so
forth. I thought I would bring it up anyway, since it helps illuminate
why such a method is useful.


More information about the xdg mailing list