[Kde-hardware-devel] org.freedesktop.PowerManagement

Richard Hughes hughsient at gmail.com
Thu Mar 22 13:48:01 PDT 2007

On Thu, 2007-03-22 at 12:36 -0700, Matt Chorman wrote:
> Same nit-picky stuff for me - It seems to me that if you are going to
> change from AC vs. Battery (to abstract the implementation of power),
> you should better name the methods and signals to "Internal" or
> "External" or something like this - this will cover any type of
> battery or external power. There are many data centers that use DC
> power on rails out to the units so using "AC" for the external power
> may not be accurate - i.e. change the signal from AcStateChanged to
> ExternalPowerStateChanged, and the method for IsOnBatteryPower to
> IsOnExternalPower... 

What about this:

    <!-- Returns the system power state, i.e. if we are running on battery power.
         Note: This method may still return true on AC using a desktop system
         if the computer is using backup power from a monitored UPS. -->
    <method name="GetBatteryState">
      <arg type="b" name="on_battery" direction="out"/>

Cheers for your help,


More information about the xdg mailing list