Proposed draft for the thumbnail D-Bus specification
hp at pobox.com
Wed Sep 3 10:51:26 PDT 2008
dbus interface name should be Thumbnailer instead of thumbnailer to
follow the naming conventions recommended in the dbus spec,
<arg type="u" name="handle" direction="out" />
integer handles are almost always wrong in dbus; using an object path
is probably more correct. A good pattern is to use a mktemp-style
random string in the object path, to avoid ever having 'recycling'
problems, even if a process restarts.
The returned object from Queue can have an interface like ThumbnailJob
and have a method Unqueue, for example.
is thumbnailer a namespace or an interface? Should probably be
More information about the xdg