[xorg-bugzilla-noise] [Bug 1510] New: xorg will use /xorg.conf if loaded from gdm

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri Oct 1 21:04:29 UTC 2004

Please do not reply to this email: if you want to comment on the bug, go to          
the URL shown below and enter yourcomments there.   
           Summary: xorg will use /xorg.conf if loaded from gdm
           Product: xorg
           Version: 6.7.0
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Server/general
        AssignedTo: xorg-bugzilla-noise at freedesktop.org
        ReportedBy: tor.klingberg at gmx.net

If there happen to exist a file /xorg.conf, then that file will be used instead
of /etc/X11/xorg.conf when X is loaded with gdm during init. 

I have this bug in Gentoo with gdm started by the Gentoo init scripts. Still, I
believe xorg should never use the file /xorg.conf

Steps to Reproduce:
1. Make sure you use x.org and gdm
2. echo FOOBAR>/xorg.conf
3. reboot

Actual Results:  
X won't start, complaining about error in xorg.conf

Expected Results:  
Used /etc/X11/xorg.conf, and started properly.

/var/log/Xorg.0.log will say 'Using config file: "//xorg.conf"'

running '/etc/init.d/xdm start' will fail the same way.
running /usr/bin/gdm does does NOT fail.

I also tried creating a trivial /etc/init.d/gdm that did nothing but 
run /usr/bin/gdm. Then running '/etc/init.d/gdm start' worked fine, but adding 
gdm to init (rc-update add gdm default) would still fail just like xdm.

I do not know if this problem also exists with kdm and xdm.

This bug is also reported in Gentoo Bugzilla at
Configure bugmail: https://freedesktop.org/bugzilla/userprefs.cgi?tab=email       
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the xorg-bugzilla-noise mailing list