[Bug 1678] New: Direct Rendering problems on IGP 320M

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Oct 20 11:00:05 PDT 2004

Please do not reply to this email: if you want to comment on the bug, go to          
the URL shown below and enter yourcomments there.   
           Summary: Direct Rendering problems on IGP 320M
           Product: xorg
           Version: unspecified
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Driver/Radeon
        AssignedTo: xorg-bugzilla-noise at freedesktop.org
        ReportedBy: tho_riedel at web.de


It seems that no newer version than XFree86 + IGP-patch from 
http://bugs.xfree86.org/show_bug.cgi?id=314 works with 3D-support 
on Amilo A 7600.
It is not important if I use a 2.4.x-kernel on SuSE 9.0 or a 2.6.x-kernel on
SuSE 9.1. I build the kernel-module from the X-Sources.
There is no framebuffer support in the kernel now (but it was no problem with
XFree86 and no other libGl-versions are exising like in bug 709.
I recently tested with Xorg 6.8.1 and latest CVS.
Compiling and installing works fine, glxinfo shows Direct Rendering=Yes but
all 3D-applications I tried to run do not work or exit with a segmentation
fault. Same with dri-CVS (I tested it some month ago because newer versions have
no option to disable IRQ-sharing needed for Amilo A).
With Xorg-CVS glxgears exits immedeately with a segmentation fault,
Tuxracer works correctly (and 3D-accelerated) until I reach the finish-line,
then it exits with segmentation fault, the resolution becomes 640x480.
My tests showed that with the appropriate IGP-patch from 
http://bugs.xfree86.org/show_bug.cgi?id=314 does not work, the bug? was probably
handed down in all later versions of XFree86 and X.org.
Because it is known that other laptops with IGP 320M have working 3D with X.org
it seems to be a special problem of the Amilo A 7600, maybe related to the bios.
I strongly assume that this problem was introduced in XFree86 with one of this changes:

633. DRI updates.
- Latest kernel drivers from the DRI trunk.

At this point the kernel-module was upgraded from 1.9 to 1.10 with
these changes:

1.10- Add SETPARAM ioctl; first parameter to set is FB_LOCATION, which
clients use to tell the DRM where they think the framebuffer is
located in the card's address space

I installed X.org-CVS from 15th of october 2004 and built the kernel
module from the IGP-patched XFree86
Before that I changed 2 things in

The line

#define __HAVE_SHARED_IRQ 1


#define __HAVE_SHARED_IRQ 0

This is always needed for 3D on Amilo A because otherwise it freezes
when radeon.o/radeon.ko is used with some other modules that have IRQ 11 at the
same time (again a problem of the bios I think!)

Then I changed the line

#define DRIVER_MINOR 9


#define DRIVER_MINOR 11

1.11 is the current radeon.h-version in X.org, if I do not change this line
the X-Server disables 3D because he detects that the radeon.o is too old.

Now the results of this "mixing":
No segmentation faults, glxinfo show Direct Rendering=Yes
glxgears works with similar frame-rates,
Tuxracer works 3D-accelerated, no segmentaton fault when reaching the
But this "solution" is not usable because the screen
looks awful, garbled, no details.

Maybe someone can do anything with it, I tried to exchange some lines
among the various versions of the files that are necessary to build
radeon.o/radeon.ko, but had no success.
I can provide log- and/or config-files if you need it.
I made a HowTo for my procedure with XFree86, I tried it similar with
X.org. It is available at 
http://www.sandrostricker.de/download/radeon IGP linux.pdf, 
the English part begins at page 11.

Configure bugmail: https://freedesktop.org/bugzilla/userprefs.cgi?tab=email       
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the xorg-bugzilla-noise mailing list