Debugging xserver on Alpha

Michael Cree mcree at
Mon Oct 12 13:51:35 PDT 2009

On 6/10/2009, at 12:28 PM, Michael Cree wrote:
> On 6/10/2009, at 11:16 AM, Matt Turner wrote:
>> On Sat, Oct 3, 2009 at 7:05 PM, Michael Cree <mcree at>
>>> I strongly suspect that the xserver is lost cycling around in the
>>> X86EMU_exec() routine and never exits it.
>>> Since the xserver 1.5 branch works on Alpha and the 1.6 branch
>>> doesn't, I
>>> did a diff of the code in the int10, x86emu, os-support/linux, etc.,
>>> directories to search for changes that might prove problematic on
>>> Alpha but
>>> I didn't spot anything that looked suspicious.
>> Does the SIS card work with 1.5?
> I should really test the SIS card with 1.5 to completely verify and  
> eliminate any
> surprises.

Oh, surprise, the SIS card does _not_ work with xserver 1.5.  I am  
seeing the same 100% continuous forever CPU usage in the int10  
initialisation code as seen with later xserver versions.  Maybe the  
problem was introduced with the PCI rewrite between xserver 1.4 and 1.5?

It also means that the problem I saw with the Radeon HD2400 is  
probably not linked with the one seen with the SIS card (i.e. my  
working hypothesis for the last couple of months has been proved  
false).  I therefore have retried the Radeon HD2400 card and it is  
working with xserver 1.7. The kernel oops I reported with xserver  
1.6.3 appears fixed in 1.7.

Given that I now have the Radeon HD2400 working, which is what I  
really wanted, I am not going to explore the problem with the (rather  
old) SIS card any further.

I did quickly test a 24bit colour capable TGA card with the tga video  
driver.  The display appears with incorrect colours - they are a bit  
mixed up.  Actually this problem extends back quite a way, certainly  
back to xserver 1.4.2 as I remember it occurring with Debian Lenny.  
Unless some Alpha users announce they desperately need to use TGA  
cards I am not going to explore the problem any further.

In summary I have xserver 1.7 running/tested on the follow:

Working with Radeon 9200 (RV280) on Compaq Alpha XP1000.  DRI works too.

Working with Radeon HD2400 (RV610) with radeon (ati) driver on  
PWS600au.  Yet to test radeonhd driver and DRI.

Working with old (1997) Matrox card on DEC PWS600au.

Problems with old SIS card (known to work with Debian Lenny v1.4.2  
xserver but not xserver 1.5 and later) and v. old TGA card (problems  
with incorrect colours going back to at least xserver 1.4.2).

>> Maybe KMS is going to be the only way we can support R600+ cards on
>> Alpha. It would be interesting to see if you got the same results  
>> as I
>> did. (

I have installed a kernel on the Compaq Alpha XP1000 with the  
Radeon 9200 card to test KMS.  The kernel comes up with the consoles  
in a 1680x1050 mode fine.  The xserver started with gdm and switched  
fine between the gdm login and the virtual consoles, but when I tried  
to log in to the Gnome desktop the system locked up; the screen went  
solid grey and I lost the keyboard, couldn't ssh in, and the console  
on the serial port locked up.  I got a response with ping. Once reset  
and rebooted I couldn't find anything in the logs that would help  
identify the problem.

I then tried running the xserver with xdm.  The xserver didn't  
complete initialisation and exited with a bus error, IIRC, in the  
fbBlt routine.  I can investigate and report on that one further if  

I was running drm git master with the --with-experimental-radeon-api  
configure option.  Have I done everything I should to properly enable  


More information about the xorg-devel mailing list