Peter Hutterer peter.hutterer at who-t.net
Wed Oct 28 16:39:56 PDT 2009

On Wed, Oct 28, 2009 at 10:15:39AM +0200, Bilko AS, Oguz Dilmac wrote:
>    Peter Hutterer yazmış:
> On Mon, Oct 26, 2009 at 11:55:07AM +0200, Bilko AS, Oguz Dilmac wrote:
> Hi,
> I need xf86-input-dmc driver to use a DMC 15" touch screen.
> I tried to get the driver from "xorg/driver/xf86-input-dmc" via git. But I
> couldn't compile it.
> This is what I get when I run ./autogen.sh
> ------------------------------------------------->
> root at Microknoppix:/home/knoppix/Desktop/dmcdnm/xf86-input-dmc# ./autogen.sh
> autoreconf: Entering directory `.'
> autoreconf: configure.ac: not using Gettext
> autoreconf: running: aclocal
> autoreconf: configure.ac: tracing
> autoreconf: running: libtoolize --copy
> libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
> libtoolize: rerunning libtoolize, to keep the correct libtool macros
> in-tree.
> libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
> autoreconf: running: /usr/bin/autoconf
> autoreconf: running: /usr/bin/autoheader
> autoreconf: running: automake --add-missing --copy --no-force
> autoreconf: Leaving directory `.'
> configure: error:
>               **************************************************************
>               This driver is unmaintained and will not receive further
>               patches. If you have a need for this driver, please file a bug
>               on http://bugs.freedesktop.org.
>               **************************************************************
> ------------------------------------------------<
> There is no Makefile generated.
> [...]
> What do you suggest?
> What am I doing wrong?
> This driver has been discontinued as it was lacking any maintainership and
> no users or bugreports against the driver could be found. Right now, it
> doesn't compile since it missed out on a few API changes that occured since
> the above error message was committed.
> See also
> http://lists.freedesktop.org/archives/xorg/2009-January/043009.html and
> http://lists.freedesktop.org/archives/xorg-devel/2009-February/000186.html
> You seem to be using Linux, so instead of resurrecting the driver a better
> option is to get the device supported by the linux kernel and not
> worry about a separate driver for X.
> This has recently been done for the dynapro driver that also used to have
> its own X driver. Now it should just work with evdev, without having to
> configure X specifically. For the dynapro commit, see
> http://git.kernel.org/?p=linux/kernel/git/dtor/input.git;a=commitdiff;h=b1680a3
> bbfb86de49bf2679b100b6f2e1ce03a27
> I really recommend going this option, the dmc driver seems to be close
> enough to dynapro that the above commit can be used as a template.
> Cheers,
>   Peter
>    Thank you, I'll try to go with your recommendation.
>    By the way, just for a note,
>    - I use knoppix 6.0 installed on a harddisk. I can see the mouse
>    pointer moving when I touch the screen. But I couldn't find how to
>    calibrate it. When I move my finger to the right the pointer goes down.

evdev has a SwapAxes, InvertX and InvertY options, the right combination of
those should get this sorted out.
it also a Calibration option that allows for some calibration if the
cursor position is a bit out from the touch points .

>    - Then I tried to install the evtouch driver from the synaptic packet
>    manager and made necessary xorg.conf changes. Now I can calibrate  it
>    via xorg.conf. But works very poorly. Evtouch driver seems to be
>    written to support many mouse input events such as right click and
>    middle mouse click etc. Therefore some times it doesn't understand if I
>    click or tried to generate another event. Infact I dont need any of
>    these events. I only need mouse up and down events (I assume click will
>    be generated automatically).
>    If you have comments on these I'd be glad to hear it.

can't comment much in regards to evtouch sorry, last time I looked at it is
a while ago and it didn't build last time I tried to.
if the touchscreen doesn't work with evdev (no clicks are generated) let me
know and we'll fix it.


More information about the xorg-devel mailing list