Fwd: Problem regarding configuring X server.

Amey Moghe amey1288 at gmail.com
Wed Sep 16 06:48:09 PDT 2009

> (EE) XKB: Couldn't open rules file /opt/gfx-test/share/X11/xkb/
> XKB: Failed to compile keymap
> Keyboard initialization failed. This could be a missing or incorrect setup
> of xkeyboard-config.
> Fatal server error:
> Failed to activate core devices.

For the above error I tried to install xkeyboard-config in /opt/gfx-test but
I am facing following error:

intltoolize: 'intltool-extract.in' exists: use '--force' to overwrite
intltoolize: 'intltool-merge.in' exists: use '--force' to overwrite
intltoolize: 'intltool-update.in' exists: use '--force' to overwrite
intltoolize: 'po/Makefile.in.in' exists: use '--force' to overwrite
autoreconf: Entering directory `.'
autoreconf: configure.in: not using Gettext
autoreconf: running: aclocal
configure.in:47: warning: macro `AM_GLIB_GNU_GETTEXT' not found in library
autoreconf: configure.in: tracing
autoreconf: configure.in: not using Libtool
autoreconf: running: /usr/bin/autoconf
autoreconf: configure.in: not using Autoheader
autoreconf: running: automake --add-missing --copy --no-force
rules/Makefile.am:184: `%'-style pattern rules are a GNU make extension
autoreconf: Leaving directory `.'
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... yes
checking for xkbcomp... /usr/bin/xkbcomp
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... none
checking for intltool >= 0.30... 0.37.1 found
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for XML::Parser... ok
./configure: line 3877: AM_GLIB_GNU_GETTEXT: command not found
configure: creating ./config.status
config.status: creating po/Makefile.in
config.status: creating Makefile
config.status: creating compat/Makefile
config.status: creating geometry/Makefile
config.status: creating geometry/digital_vndr/Makefile
config.status: creating geometry/sgi_vndr/Makefile
config.status: creating keycodes/Makefile
config.status: creating keycodes/digital_vndr/Makefile
config.status: creating keycodes/sgi_vndr/Makefile
config.status: creating keymap/Makefile
config.status: creating keymap/digital_vndr/Makefile
config.status: creating keymap/sgi_vndr/Makefile
config.status: creating keymap/sun_vndr/Makefile
config.status: creating semantics/Makefile
config.status: creating rules/Makefile
config.status: creating rules/bin/Makefile
config.status: creating rules/compat/Makefile
config.status: creating rules/extras/Makefile
config.status: creating symbols/Makefile
config.status: creating symbols/digital_vndr/Makefile
config.status: creating symbols/fujitsu_vndr/Makefile
config.status: creating symbols/hp_vndr/Makefile
config.status: creating symbols/macintosh_vndr/Makefile
config.status: creating symbols/nec_vndr/Makefile
config.status: creating symbols/sgi_vndr/Makefile
config.status: creating symbols/sony_vndr/Makefile
config.status: creating symbols/sun_vndr/Makefile
config.status: creating symbols/xfree68_vndr/Makefile
config.status: creating symbols/extras/Makefile
config.status: creating types/Makefile
config.status: creating xkeyboard-config.spec
config.status: creating docs/Makefile
config.status: executing depfiles commands
config.status: executing intltool commands
config.status: executing po/stamp-it commands
config.status: error: po/Makefile is not ready.

So I tried to install package po from aptitude but that also didn't work.

P.S. Actually we require X server configuration for MPX.

On Wed, Sep 16, 2009 at 6:49 PM, Dan Nicholson <dbn.lists at gmail.com> wrote:

> On Wed, Sep 16, 2009 at 4:01 AM, Amey Moghe <amey1288 at gmail.com> wrote:
> > Hello all ,
> >             I am an undergraduate student, is configuring X server as a
> part
> > of my project. I followed the shell script and the other instructions
> given
> > in the link which is as follows:
> >
> > http://www.x.org/wiki/Development/git
> >
> > After all the configuration done without any dependencies remaining, as
> per
> > given in the link I tried to execute following command:
> >
> > rmmod i915
> >
> > But it was flashing error that 'i915 is running'
> >
> > so couldn't execute further commands. which are as follows:
> >
> > rmmod drm
> >
> > insmod <path_to_drm_tree_above>/linux-core/drm.ko
> >
> > insmod <path_to_drm_tree_above>/linux-core/i915.ko
> These instructions are a little old. The development of the drm
> modules is all done within the linux kernel tree now. So, you just
> need to compile a newer kernel if you want to upgrade these. If you
> are running on newer distro releases, you're usually fine using the
> ones supplied. Except...
> > So at last I set path for the LD_LIBRARY_PATH=/opt/gfx-test/lib
> >
> > ( I have used variables as follows:
> >  PKG_CONFIG_PATH=/opt/gfx-test/lib/pkgconfig
> >  ACLOCAL="aclocal -I $PREFIX/share/aclocal
> > also I used prefix option with --prefix=/opt/gfx-test )
> >
> > and to start X server ,executed following command:
> >
> > startx -- /opt/gfx-test/bin/Xorg -verbose
> >
> > But I faced following text as an error:
> >
> >
> > This is a pre-release version of the X server from The X.Org Foundation.
> > It is not supported in any way.
> > Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
> > Select the "xorg" product for bugs you find in this release.
> > Before reporting bugs in pre-release versions please check the
> > latest version in the X.Org Foundation git repository.
> > See http://wiki.x.org/wiki/GitPage for git access instructions.
> >
> > X.Org X Server (1.7.0 RC 1)
> > Release Date: (unreleased)
> > X Protocol Version 11, Revision 0
> > Build Operating System: Linux 2.6.24-16-generic i686
> > Current Operating System: Linux projectmachine4 2.6.24-16-generic #1 SMP
> Thu
> > Apr 10 13:23:42 UTC 2008 i686
> This kernel is too old. If you really want to use the drm
> capabilities, you'll need at least linux-2.6.29, but better would be
> linux-2.6.30 or linux-2.6.31.
> If you can't install a newer kernel on this machine, you can still use
> X. I don't know what your project is, but this situation mostly means
> you won't have accelerated 3D.
> <snip>
> > (EE) XKB: Couldn't open rules file /opt/gfx-test/share/X11/xkb/rules/base
> > XKB: Failed to compile keymap
> > Keyboard initialization failed. This could be a missing or incorrect
> setup
> > of xkeyboard-config.
> >
> > Fatal server error:
> > Failed to activate core devices.
> Did you install xkeyboard-config in /opt/gfx-test? You'll also likely
> need to install xkbcomp in /opt/gfx-test/bin or make a symlink to your
> distro's xkbcomp.
> --
> Dan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.x.org/archives/xorg-devel/attachments/20090916/2e63327e/attachment.htm 

More information about the xorg-devel mailing list