[PATCH] Eliminate per-test timing calibration.

Alan Coopersmith Alan.Coopersmith at Sun.COM
Thu Jan 7 13:25:03 PST 2010


Peter Harris wrote:
> Also, "inline" is a C99ism. Should that read _X_INLINE to support C89
> compilers?

Don't we already assume that level of C99 support in other modules?

_X_INLINE should only be used in exported headers these days anyways,
where you don't control the compilation environment it's included in,
but you don't want to repeat the Xlib mistake of making your implementation
details become ABI by doing too much of that.

For code being built directly, just use AC_C_INLINE and let it #define
inline to "" or "__inline__" if needed (though in most cases it will
leave it undefined) - that way the code's easier to read and people
don't need to go lookup what the difference is between _X_INLINE and inline.

-- 
	-Alan Coopersmith-           alan.coopersmith at sun.com
	 Sun Microsystems, Inc. - X Window System Engineering



More information about the xorg-devel mailing list