Failure in detecting keyboard

Peter Hutterer peter.hutterer at
Sun Jan 31 16:58:40 PST 2010

On Sat, Jan 30, 2010 at 09:17:12AM +0530, Amey wrote:
> Hello all,
>                I am a final year graduate student and I am trying to
> configure X server.In that when I tried to run X server after all the
> configuration done with following commands:
> *1) sudo /etc/init.d/gdm stop
> 2) sudo startx -- /opt/mpx/bin/Xorg verbose :0   (P.S. I installed all the
> packages with prefix /opt/mpx )
> *
> then X server didn't run initialy  and I got the following log:
> (II) AIGLX: Loaded and initialized /opt/mpx/lib/dri/
> (II) GLX: Initialized DRISWRAST GL provider for screen 0
> (II) NV(0): Setting screen physical size to 338 x 211
> (EE) Error compiling keymap (server-0)
> (EE) XKB: Couldn't compile keymap
> XKB: Failed to compile keymap
> Keyboard initialization failed. This could be a missing or incorrect setup
> of xkeyboard-config.

This is often the case if /opt/mpx/share/X11/xkb/compiled/ doesn't exist or
isn't writable. Check for that too.
> For above error  I configured xkeyboard-config package with prefix /opt/mpx/
> and again tried to run X server with above sequence of  commands.But still
> error was there. So checked for "xkbcomp" in /opt/mpx then found it here:
> /opt/mpx/share/X11/xkb

this is weird, xkbcomp should not be in this directory. Please reconfigure
with the right prefix and reinstall instead of the symlink.
that aside - is there any reason you disable hotplugging?


More information about the xorg-devel mailing list