[ANNOUNCE] xorg-server

Timo Aaltonen timo.aaltonen at aalto.fi
Thu Mar 25 12:45:27 PDT 2010

On Thu, 25 Mar 2010, Ruediger Oertel wrote:

>> Do you have any backtrace information?
> sure ...
> Program received signal SIGSEGV, Segmentation fault.
> 0x000000000055fe4f in DeliverPropertyEvent (pWin=0x4545454545454545, value=0x7fffffffdf00) at rrproperty.c:34
> 34      rrproperty.c: No such file or directory.
>        in rrproperty.c
> (gdb) bt
> #0  0x000000000055fe4f in DeliverPropertyEvent (pWin=0x4545454545454545, value=0x7fffffffdf00) at rrproperty.c:34
> #1  0x0000000000443e85 in TraverseTree (pWin=0x87dd00, func=0x55fe30 <DeliverPropertyEvent>, data=0x7fffffffdf00) at window.c:233
> #2  0x000000000055ff4e in RRDeleteAllOutputProperties (output=0x838fe0) at rrproperty.c:77
> #3  0x000000000049d41b in RROutputDestroyResource (value=0x838fe0, pid=<value optimized out>) at rroutput.c:413
> #4  0x0000000000456f13 in FreeClientResources (client=<value optimized out>) at resource.c:810
> #5  0x0000000000456fe9 in FreeAllResources () at resource.c:827
> #6  0x0000000000425bb1 in main (argc=<value optimized out>, argv=<value optimized out>, envp=<value optimized out>) at main.c:300

Do you mean that it crashes when you stop/restart the server (which 
usually happens on logout). Have you tried it on top of 1.7.x? I have, and 
it doesn't crash there.. tried on my laptop with intel, and it loads vesa 
and fbdev as well.

Timo Aaltonen
Systems Specialist
IT Services, Aalto University School of Science and Technology

More information about the xorg-devel mailing list