[ANNOUNCE] xorg-server

Ruediger Oertel ro at suse.de
Thu Mar 25 17:43:24 PDT 2010

On Friday 26 March 2010 00:22:00 Ruediger Oertel wrote:
> On Thursday 25 March 2010 22:55:13 Timo Aaltonen wrote:
> > >> yes, for some reason it does not happen with the intel driver (or
> > >> probably other combinations with only one native driver plus fbdev and
> > >> vesa). Maybe that's a way to look: something in the screen setup may
> > >> be different for fbdev or vesa, I'll try to look later on.
> > >> 
> > >> my simple test to reproduce is just starting the xserver plus an xterm
> > >> on it and then exiting the xterm.
> > > 
> > > Crap, sounds like I need to try in on the desktop with nouveau/blob/nv
> > > :)
> > 
> > Still no crash even with that machine. Tried several different scenarios:
> > 
> > - nvidia loaded (nouveau blacklisted), nv/nouveau available/missing
> > - nouveau loaded, nv/nvidia available/missing
> > 
> > so I guess that leaves hybrids like intel/ati, intel/nvidia, ati/nvidia
> > that are crashing?
> argh, I apologize for leaving one important fact aside:
> I'm running with malloc checking on:
> # set | grep MALLOC
> if I unset MALLOC_PERTURB_, the Xserver will run pretty happily without
> crashing on cleanup. still I'm pretty sure it's a valid problem as I'm
> producing structures that will cause a double-free on cleanup.

sigh ... and once I had realized this, I played with that some more:
- the patch does pretty sure not cause the segfault
- backed out my patch, rebuilt, run with MALLOC_* set and get the crash
- backed out all distro patches, rebuilt  xorg-server-
  and still see the crash (config with driver="nouveau" selected)
in other words: the machines with the intel driver where I thought I could
not reproduce the crash on, most likely did not have MALLOC_* set

and I've spent almost two days chasing a segfault in my patch without
even realizing it was elsewhere ...

so IMHO here are two things:
- please continue the review of my patch for possible inclusion

- does anyone have an idea what's causing this crash with the vanilla xserver:
0: ./xorg-server- (xorg_backtrace+0x28) [0x462148]
1: ./xorg-server- (0x400000+0x65f69) [0x465f69]
2: /lib64/libc.so.6 (0x7fb4e3122000+0x329f0) [0x7fb4e31549f0]
3: ./xorg-server- (0x400000+0x15edff) [0x55edff]
4: ./xorg-server- (TraverseTree+0x85) [0x443d25]
5: ./xorg-server- (RRDeleteAllOutputProperties+0x6e) [0x55eefe]
6: ./xorg-server- (0x400000+0x9caab) [0x49caab]
7: ./xorg-server- (FreeClientResources+0xd3) [0x456db3]
8: ./xorg-server- (FreeAllResources+0x49) [0x456e89]
9: ./xorg-server- (0x400000+0x25b11) [0x425b11]
10: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7fb4e3140b7d]
11: ./xorg-server- (0x400000+0x25699) [0x425699]
Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

as it may be related: > gcc --version
gcc (SUSE Linux) 4.5.0 20100311 (experimental) [trunk revision 157384]

CFLAGS='-O2 -fmessage-length=0 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -g -fno-strict-aliasing'

with kind regards (mit freundlichem Grinsen),
   Ruediger Oertel (ro at novell.com,ro at suse.de,bugfinder at t-online.de)
Linux MacBookRudi.suse.de 2.6.33-6-desktop #1 SMP PREEMPT 2010-02-25 20:06:12 +0100 x86_64
Key fingerprint = 17DC 6553 86A7 384B 53C5  CA5C 3CE4 F2E7 23F2 B417
SUSE LINUX Products GmbH,  GF: Markus Rex,   HRB 16746 (AG Nürnberg)

More information about the xorg-devel mailing list