[PATCH v2 5/6] composite: Support updating an arbitrary subtree
ville.syrjala at nokia.com
Mon Jan 3 11:45:49 PST 2011
On Mon, Jan 03, 2011 at 09:21:40AM -0800, Keith Packard wrote:
> On Mon, 3 Jan 2011 15:54:54 +0200, Ville Syrjälä <ville.syrjala at nokia.com> wrote:
> > How about this? Stills leaves the compChildrenUpdate name there
> > though.
> Yeah, the structure looks good. I still don't like the names, as
> compWindowUpdate paints a window into its parent (updating the parent)
> and compChildrenUpdate updates the window (along with the
> children). Naming is hard.
Indeed. compPaintWindowToParent + compPaintChildrenToWindow?
That would still leave compWindowUpdateAutomatic somewhat misnamed.
compPaintWindowToParentAutomatic would be quite a mouthful :)
More information about the xorg-devel