xserver distcheck broken with and without --disable-devel-docs

Daniel Stone daniel at fooishbar.org
Wed Jan 5 06:15:26 PST 2011

On Mon, Jan 03, 2011 at 10:25:35PM -0800, Keith Packard wrote:
> On Mon, 03 Jan 2011 17:52:10 -0500, Gaetan Nadon <memsize at videotron.ca> wrote:
> > In the last path I did on master
> > http://cgit.freedesktop.org/xorg/xserver/commit/?id=03ea0b7726487b96df73936518da73d023e51334
> > I had tested those various scenarios and worked correctly.
> It worked for me today. I recall discussing this at the time the change
> was made to require suitable tools to produce the canonical distribution
> tarball. You don't get an option to not build the docs for the tarball.

Sure, and I've no problem with that, but I'd like to be able to run
distcheck and have it work even if the tree I run distcheck from has
docs disabled.  (Which it does, because docs are the longest individual
part of my build, other than linking libxorg.la.)

You should be able to reproduce this really easily:
git clone fdo:xorg/xserver
cd xserver
mkdir build
cd build
make distcheck

Two patches to fix distcheck when building with srcdir != builddir will
follow in a reply to this, and are also at
git://people.freedesktop.org/~daniels/xserver as the first two commits
on master.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://lists.x.org/archives/xorg-devel/attachments/20110105/4de31ff7/attachment.pgp>

More information about the xorg-devel mailing list