[PULL] BUG_WARN, input cleanup and mask size fix
Peter Hutterer
peter.hutterer at who-t.net
Mon Nov 28 21:53:11 PST 2011
Some cleanup fixes c-p from my multitouch branch, nothing intrusive. Real
changes here is the introduction of the BUG_WARN macro (no user yet) and a
fix in the input mask size calculation that won't trigger until we add more
events.
commit dfcec1d3f9d7bac5cde9eb034341428ee0ad3728
The following changes since commit b2015a2c01711646bb7ae23d684abee0cd55d4d0:
dmx: Build fix for -Werror=implicit-function-declaration on linux (2011-11-24 21:15:32 -0800)
are available in the git repository at:
git://people.freedesktop.org/~whot/xserver for-keith
Peter Hutterer (8):
include: fix mask size calculation
Xi: use single return code from XIPassiveGrabDevice
dix: rename GetWindowXI2Mask to WindowXI2MaskIsset
dix: use a single return statement in CheckPassiveGrabsOnWindow
Xi: add helper functions to alloc/free InputClientPtrs
Xi: add FreeInputMask function
include: add BUG_WARN macro for internal bug cases.
test: remove unneeded printf statements from misc.c
Xi/exevents.c | 35 ++++++++++++++++++++++++++++-------
Xi/xipassivegrab.c | 36 ++++++++++++++++++++----------------
dix/events.c | 25 +++++++++++++------------
include/input.h | 2 +-
include/inputstr.h | 2 +-
include/misc.h | 7 +++++++
test/misc.c | 3 ---
7 files changed, 70 insertions(+), 40 deletions(-)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg-devel/attachments/20111129/0d4b3a8c/attachment.pgp>
More information about the xorg-devel
mailing list