Display Link Adapter Hot-Swapping with xorg-server 1.13.0 and xrandr 1.4

Sam Lanning sam at samlanning.com
Sun Nov 4 06:35:52 PST 2012

On 11/04/2012 10:18 AM, Dave Airlie wrote:
> On Sun, Nov 4, 2012 at 1:17 PM, Sam Lanning <sam at samlanning.com> wrote:
>> Hey Everyone,
>> I'm new sending questions to this list so please forgive me. I wasn't sure
>> whether this should be directed at the devel list or users list.
>> I am trying to get my DisplayLink adapter working with my Dell Vostro 3700
>> laptop. With nvidia optimus card.
>> I came across Dave Airlie's work on hot-swapping slave USB gpus. And
>> discovered his git repo on freedesktop.org
>> http://people.freedesktop.org/~airlied/prime-notes.txt
>> I have tried to compile each of the parts (from the prime branch), but came
>> across trouble with compiling a few of them.
>> Mesa: The first problem occurred when i tried to autogen. It couldnt find a
>> version of libdrm_nouveau greater than 0.6. I solved this with setting the
>> environment variables:
>> NOUVEAU_LIBS=/usr/lib/libdrm_nouveau2.so.2:/usr/lib/libdrm_nouveau2.so.2.0.0
>> so the make files were then generated fine.
>> At compile time, make seems to get stuck in a loop constantly touching and
>> rm-f ing depend. And entering and leaving the directory src/glsl/.
>> The second compile problem occurs when trying to create the make file for
>> xf86-video-nouveau. It comes up with this error after running autogen.sh
>> ./configure: line 11987: syntax error near unexpected token `RANDR,'
>> ./configure: line 11987: `XORG_DRIVER_CHECK_EXT(RANDR, randrproto)'
>> Any help would be greatly appreciated.
> Just get everything from upstream, nothing is in my personal branches
> anymore. Everything should be released except for xrandr which you can
> build from git.
> Dave.

Ahh ok then,

When i try and compile the current source from the repo
git://anongit.freedesktop.org/xorg/app/xrandr i get some errors at
compile time:

xrandr.o: In function `main':
.../xrandr.c:2969: undefined reference to `XRRSetProviderOffloadSink'
.../xrandr.c:2965: undefined reference to `XRRSetProviderOutputSource'
.../xrandr.c:3392: undefined reference to `XRRGetProviderResources'
.../xrandr.c:3397: undefined reference to `XRRGetProviderInfo'
.../xrandr.c:3404: undefined reference to `XRRFreeProviderInfo'
collect2: error: ld returned 1 exit status

I guess I'm missing some header files somewhere? But i'm not sure what
and autoconf didn't pick up on anything.


More information about the xorg-devel mailing list