Display Link Adapter Hot-Swapping with xorg-server 1.13.0 and xrandr 1.4

Sam Lanning sam at samlanning.com
Tue Nov 6 07:38:04 PST 2012

On 11/05/2012 04:31 PM, Daniel Martin wrote:
> On Mon, Nov 05, 2012 at 01:22:28PM +0000, Sam Lanning wrote:
>> On 11/04/2012 10:12 PM, Dave Airlie wrote:
>>> On Mon, Nov 5, 2012 at 12:35 AM, Sam Lanning <sam at samlanning.com> wrote:
>>>> On 11/04/2012 10:18 AM, Dave Airlie wrote:
>>>>> On Sun, Nov 4, 2012 at 1:17 PM, Sam Lanning <sam at samlanning.com> wrote:
>>>>>> Mesa: The first problem occurred when i tried to autogen. It couldnt find a
>>>>>> version of libdrm_nouveau greater than 0.6. I solved this with setting the
>>>>>> environment variables:
>>>>>> NOUVEAU_LIBS=/usr/lib/libdrm_nouveau2.so.2:/usr/lib/libdrm_nouveau2.so.2.0.0
>>>>>> NOUVEAU_CFLAGS=empty
> You've build and installed libdrm before? If it's installed in a non
> standard path you have to tell pkg-config where it has to search for it
I did build and install libdrm. It created:


I got these values from pkg-config:

pkg-config --modversion libdrm

pkg-config --modversion libdrm_nouveau

pkg-config --modversion libdrm_nouveau2

So setting the environment variables pointed it to libdrm_nouveau2
rather than libdrm_nouveau.
>>>>> The second compile problem occurs when trying to create the make file for
>>>>> xf86-video-nouveau. It comes up with this error after running autogen.sh
>>>>> ./configure: line 11987: syntax error near unexpected token `RANDR,'
>>>>> ./configure: line 11987: `XORG_DRIVER_CHECK_EXT(RANDR, randrproto)'
> I'm unsure about that. Do you've installed the development packages for
> util-macros and xorg-server?
> Do those files exist:
>     /usr/share/aclocal/xorg-macros.m4
>     /usr/share/aclocal/xorg-server.m4
> The macro XORG_DRIVER_CHECK_EXT is defined in the latter one.
According to David Airlie, i shouldn't need to use his repos any more, i
built xorg-server 1.13.0 from the git repo successfully prior to this.
So i don't need to worry about these any more.

I did have xorg-macros, but not xorg-server. But it shouldn't produce a
syntax error for an undefined macro should it?
>>>> When i try and compile the current source from the repo
>>>> git://anongit.freedesktop.org/xorg/app/xrandr i get some errors at
>>>> compile time:
>>>> xrandr.o: In function `main':
>>>> .../xrandr.c:2969: undefined reference to `XRRSetProviderOffloadSink'
>>>> .../xrandr.c:2965: undefined reference to `XRRSetProviderOutputSource'
>>>> .../xrandr.c:3392: undefined reference to `XRRGetProviderResources'
>>>> .../xrandr.c:3397: undefined reference to `XRRGetProviderInfo'
>>>> .../xrandr.c:3404: undefined reference to `XRRFreeProviderInfo'
>>>> collect2: error: ld returned 1 exit status
>>> you need libXrandr.
> configure should have checked for libXrandr and it should have failed if
> it's not available. What's the output of:
>     pkg-config --libs xrandr
> Cheers,
>     Daniel
Also the result of the above command is this:

$ pkg-config --libs xrandr

Any further advice?

Sam.xorg-devel at lists.x.org

More information about the xorg-devel mailing list