Problem with compiling the X server

Check Nyah check.nyah at
Sat Jul 19 08:21:25 PDT 2014

I"ve tried installing libXfont and it still returns this error

* Package requirements (xproto xtrans fontsproto >= 2.1.3 fontenc) were not
met:No package 'xtrans' foundRequested 'fontsproto >= 2.1.3' but version of
FontsProto is 2.1.2No package 'fontenc' foundConsider adjusting the
PKG_CONFIG_PATH environment variable if youinstalled software in a
non-standard prefix.Alternatively, you may set the environment variables
XFONT_CFLAGSand XFONT_LIBS to avoid the need to call pkg-config.See the
pkg-config man page for more details.*

I have installed xproto and xtrans I  added the PKG_CONFIG_PATH to the
right directory, what I don't understand is how to upgrade the packages
needed for installing X server and how to upgrade fontsproto and the others
for the X server. I tried yum but it does not seem to work.


On Sat, Jul 19, 2014 at 4:15 PM, Julien Cristau <jcristau at> wrote:

> On Sat, Jul 19, 2014 at 14:58:19 +0100, Check Nyah wrote:
> > Hi,
> > I'm trying to compile the X server and I've installed all the required
> > dependencies and I still get this error
> > while I installed the git clone for So how do i
> > upgrade these packages then.
> >
> That says you're missing libXfont...
> Cheers,
> Julien
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the xorg-devel mailing list