Odd problems with dualhead mode

Jason L Tibbitts III tibbs at math.uh.edu
Fri Oct 1 07:55:42 PDT 2004

I'm running a 2880x1200 desktop made from a 1280x1024 19" panel and a
1600x1280 21" panel off of a Radeon 9200 card.  (I'm running FC2 fully
updated, which means Xorg 6.7.0; I will try to test something more
recent but it's difficult to duplicate my production setup.)
Everything works beautifully, but a couple of applications experience
some odd behavior and I'm having trouble figuring out who is at fault.

When I run xemacs, it hangs with a partially drawn window (in fact,
just the first "F" of the file menu is drawn).  If I kill it and
restart it, it runs fine.

When I run Matlab (R14SP1) and run a particular demo (the Wavelet 1-D
GUI demo) it will always hang at one point the first time I run it,
but if I kill it and start again it will always hang at a later point.

Both applications have no trouble at all if I reconfigure to a single

The commonality between the two behaviors is rather odd to me since
the applications share nothing.  (Most of Matlab is in Java and xemacs
links with Xaw3d.)  So I figured I'd start with X and see if anyone's
seen anything similar.

 - J<

More information about the xorg mailing list