Xorg 6.8.1: can't switch VT or resolution (partially solved)

Glynn Clements glynn.clements at virgin.net
Sat Oct 2 01:13:43 PDT 2004

Corey Hickey wrote:

> >>and it seemed that libxkbfile.so.1 wasn't found until I `export
> >>LD_LIBRARY_PATH=/usr/local/X11R6cvs/lib/` after which ldd showed all the
> >>libraries. The strange thing is, I have LD_LIBRARY_PATH set in the
> >>console from which I start xorg. I tried unsetting LD_LIBRARY_PATH, and
> >>it did make a difference: xorg wouldn't load, with the console output
> >>saved and attached as nold.log.
> > 
> > 
> > The X server strips out all LD* variables from the environment for 
> > security.  See xc/programs/Xserver/os/utils.c:1847.
> Once again, thank you for your help. Modifying utils.c to not strip LD*
> would suit my purposes for now, but I'm having trouble doing so.


> Now that I'm leaving the permissions of xterm alone, the LD* stripping
> results in xterm failing to load as well. I don't know how the file
> permissions fit in, but it seems that as long as I can preserve
> LD_LIBRARY_PATH I won't have any trouble with xterm either.

The Linux loader (ld-linux.so) also deletes the LD_* variables when
running a setuid/setgid program.

Glynn Clements <glynn.clements at virgin.net>

More information about the xorg mailing list