build problems

Gene Heskett gene.heskett at
Mon Sep 13 07:30:34 PDT 2004

On Monday 13 September 2004 00:04, Gene Heskett wrote:

Yeah, I know, its considered to be 'poor form' to answer ones own 

>Couple of things on an x86 (athlon) FC2 system.  Dl'd, and md5sums'd
> the downloads, then unpacked all 7 files, made a /usr/src/buildx6.8
> dir, cd'd to it and did the lndir ../xc thing.  Re-read the docs
> and could see that there wasn't anything I could do, so I started
> the make World as shown in the BUILD doc.

The error I'll snip below was because I'd not nuked the xc dir before 
unpacking 6.8, so there was a 6.7 in there too.  Duh!


I nuked it all, and unpacked fresh, and I now have an advisory line in 
that cli where the tail is running that reads:
Mon Sep 13 03:57:04 EDT 2004

Full build of Release 6.8 complete.
Which didn't take as long as I'd estimated, only something in the 1 to 
2 hour range.

However this is still a valid question.  At least I assume one could 
keep it up to date with a weekly cvs fetch.

>Then I tried a 'cvs up -dP', which has worked lots of times
>with other large projects like kde, and got this:
>[root at coyote buildx6.8]# cvs up -dP
>cvs update: No CVSROOT specified!  Please use the `-d' option
>cvs [update aborted]: or set the CVSROOT environment variable.
>[root at coyote buildx6.8]#
>So what do I put in the -d"argument"?

FWIW, I logged out of X, with the beginnings of this message still 
sitting on screen, cd'd to /usr/src/buildX6.8 and did a 'make 
install', then restarted X with the usual startx.  It might be a hair 
slower, but everything was restored.  I'm impressed, I've always had 
to save any messages being edited in drafts, and close kmail by hand 
before doing an X restart.

My newest hat, a blue baseball style that says in large type, "I'm 
retired", and in smaller type under that "This is as dressed up as I 
get", is off to you folks.  I have good feelings about this release. 

The first thing I notice is that apparently the kmail editor, and in 
some other apps too, the cursor motions using the arrow keys are at 
the keyboard repeat rate instead of about once a second, which was 
the case 80% of the time with 6.7.  That problem came and went, 
working correctly about 20% of the time, and was very frustrating 
when trying to backspace and correct a typo these old fingers are 
prone to doing.  It was far quicker to pick up the mouse and move the 
cursor with the mouse pointer.  A hearty hurrah and another tip of 
the hat to the coder(s) that fixed that one.

Now, is there anything I can put in the xorg.conf that will 
accellerate this "X-tacy" branded radeon 9200SE enough to play 
something like tuxracer on it?

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
99.26% setiathome rank, not too shabby for a WV hillbilly attorneys please note, additions to this message
by Gene Heskett are:
Copyright 2004 by Maurice Eugene Heskett, all rights reserved.

More information about the xorg mailing list