can't run gtk programs on Xvfb with a color depth of 16 or 24. why?

dave giffin givdav01 at
Mon Sep 20 01:00:32 PDT 2004

I want to run mozilla on Xvfb to get some screenshots
of web pages.

I start Xvfb with the command:

Xvfb :30 -ac -screen 0 1024x768x24

Which creates an Xvfb server with 1024x768 resolution
and a color depth of 24 (16.7 million colors).

Then I run mozilla:

mozilla --display :30.0

And get the following error message:

Gdk-ERROR **: BadLength (poly request too large or
internal Xlib length erro
  serial 1240 error_code 16 request_code 148
minor_code 20

I've tried other programs like gshell, gedit with the
same problem. 

I also have the same problem with a color depth of 16.
But, when I run Xvfb with a color depth of 8 (only 256
colors), gtk programs run fine.

If I run a Qt based program, with a depth of 16 or 24,
when I try to take a screenshot, my screenshot program
(graphicsmagick) locks up.

I am running Redhat 9 on an i686 with XFree86-Xvfb 4.3

Why is this happening?  Is there a solution?


Do you Yahoo!?
Declare Yourself - Register online to vote today!

More information about the xorg mailing list