Xorg 6.8.1: can't switch VT or resolution

Corey Hickey bugfood-ml at fatooh.org
Fri Sep 24 18:54:28 PDT 2004


I just installed Xorg 6.8.1 on my Debian GNU/Linux system, roughly
according to the directions listed here:

As far as I can tell, everything is working properly except that I am
unable to switch to a different VT with the usual CTRL-ALT-Fn
combination or change resolutions using CTRL-ALT-+ or CTRL-ALT--.

My xorg.conf file is attached, and I am starting xorg with the following

$ export LD_LIBRARY_PATH=/usr/local/X11R6.8/lib
$ export PATH=/usr/local/X11R6.8/bin:$PATH
$ xinit /usr/local/X11R6.8/bin/xterm -- /usr/local/X11R6.8/bin/X :1 vt8
-layout default

Nothing happens when I press CTRL-ALT-F1. If I move the mouse so the
xterm window is in focus and press CTRL-ALT-F1, the xterm window prints
a P. Each Fn key prints something different, either a letter like P or
something like 5;7~ (I suppose xterm is recieving a non-printable
character code). CTRL-ALT-+ prints a + and CTRL-ALT-- prints a -.

CTRL-ALT-Backspace works fine.  :)

I tried adding each of the following ServerFlags, but no luck:
  Option "DontVTSwitch" "false"
  Option "HandleSpecialKeys" "Always"

I suspect that something is wrong with my keyboard configuration, but my
xorg.conf tweaking hasn't resulted in success. The keyboard section
right now is:

Section "InputDevice"
        Identifier      "MS Natural"
        Driver          "kbd"
        Option          "CoreKeyboard"
#       Option          "XkbRules"      "xfree86"
        Option          "XkbModel"      "microsoft"
        Option          "XKbOptions"    ""
#       Option          "XkbLayout"     "us"

Within this section, I tried the following modifications one-by-one with
no luck:
- Change Driver to "keyboard"
- Uncomment Option "XkbRules" "xfree86"
- Change Option "XkbModel" to "pc104" or "pc101"
- Uncomment "XkbLayout" "us"

After all that, I have to admit that I am completely stumped. I've read
all the documentation I could find, looked on Google, looked under the
bed, and so far I don't even know what the cause of the problem is.

I've attached Xorg.1.log and xorg.conf. Here's some system information
that could be relevant:
AthlonXP 3000+
GeForce FX 5900
Debian testing/Sarge
Xorg 6.8.1
GCC 3.3.4

If I've omitted any information, please let me know.

Thank you for your help,
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: xorg.conf
URL: <http://lists.x.org/archives/xorg/attachments/20040924/63f06eae/attachment.ksh>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.1.log.bz2
Type: application/octet-stream
Size: 6513 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20040924/63f06eae/attachment.obj>

More information about the xorg mailing list