Failing reach more then 1280x1024 with intel 945G chipset

Alex Deucher alexdeucher at
Fri Aug 12 06:33:59 PDT 2005

On 8/12/05, Milos Mulac <mulac at> wrote:
> Hi,
> I have a problem with i810 driver (or maybe better to say with
> intels's 945G chipset).
> I use onboar graphic chip (GMA 950 (part of 945chipset)), LCD with native
> resolution 1680x1050, kernel, cvs xorg (but I tried
> also Xfree 4.3, xfree from cvs, intel's driver - no success)
> I have tried both vesa and i810 driver. In both cases I reach only
> resolution 1280x1024. I see strange lines in logs ('no mode of this name'
> - it looks like definition of modeline in monitor section is not used). I
> include both vesa and i810 logs because both seems interesting.
> I would be grateful for any suggestion how to solve this problem.

Please check the lists in the future.  It's been said numerous times;
the intel driver relies on  the video bios to set modes.  if the bios
doesn't support the mode you want, it can't set it.  This is the case
with your 1680x1050 mode.  You can try utilities like i915resolution
or Alanh's latest testing driver which does a similar thing.


> Best regards,
> Milos.
> PS: lspci output, Conf file, VESA & i810 logs
> lspci
> 0000:00:02.0 VGA compatible controller: Intel Corp.: Unknown device 2772 (rev 02)
> 0000:00:02.1 Display controller: Intel Corp.: Unknown device 2776 (rev 02)
> ....

More information about the xorg mailing list