_glthread_TSD problem [was: display lists broken in Mesa maybe due to glapi dispatch changes (?), and an Xthreads problem]

Sergio Monteiro Basto sergio at sergiomb.no-ip.org
Mon Aug 29 19:35:42 PDT 2005


The s3v and savage drivers did not compile with exactly the same error.
I hit this problem on X.org CVS with Mesa from there.
Since Mesa on X.org is the stable branch 6.3.2, is your fix there ? 
or anyone knows how fix this problem.
I can get build the others DRI drives. 
But make linux-dri-x86 has a strange bug, enter in loop in the finish of
building and I have to stop it with Ctrl+C.


On Mon, 2005-08-01 at 09:37 -0700, Ian Romanick wrote:
> It builds fine on my main machine.  I tried a build on a fresh system
> install (with X.org CVS installed) and hit the same problem.  I
> committed a fix for it just a few minutes ago.  I think the problem here
> is related to the next problem...
> > And, even with that change, the s3v and savage drivers did not compile,
> > both failed the same way (though I didn't care too much as I only needed
> > r200 anyway...).
> > gcc -c -I. -I../../../../../src/mesa/drivers/dri/common -Iserver
> > -I../../../../../../dri/drm/shared-core -I../../../../../include
> > -I../../../../../include/GL/internal -I../../../../../src/mesa
> > -I../../../../../src/mesa/main -I../../../../../src/mesa/glapi
> > -I../../../../../src/mesa/math -I../../../../../src/mesa/transform
> > -I../../../../../src/mesa/shader -I../../../../../src/mesa/swrast
> > -I../../../../../src/mesa/swrast_setup -I../../../../../src/egl/main
> > -I../dri_client -I../dri_client/imports -Wall -O -g  -m32
> > -DUSE_SSE_ASM -std=c99 -ffast-math  -D_POSIX_SOURCE
> > -DGLX_DIRECT_RENDERING s3v_state.c -o s3v_state.o
> > In file included from ../../../../../src/mesa/main/mtypes.h:41,
> >                  from s3v_screen.h:5,
> >                  from s3v_context.h:13,
> >                  from s3v_state.c:6:
> > ../../../../../src/mesa/glapi/glthread.h:202: error: conflicting types
> > for `_glthread_TSD'
> > ../../../../../src/mesa/glapi/glthread.h:92: error: previous declaration
> > of `_glthread_TSD'
> The only way this could happen is if *both* PTHREADS and XTHREADS are
> defined.  I suspect the Xthreads.h problem was always there, but it was
> never hit because XTHREADS was never defined.  Some how, somewhere,
> XTHREADS is getting set.  I'll have to look into it, but I think this is
> a bug in whatever X.org header is defining XTHREADS for us. :(

Sérgio M.B.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 2166 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20050830/c092b980/attachment.bin>

More information about the xorg mailing list