X won't start; consumes all CPU

Margaret_Doll Margaret_Doll at brown.edu
Fri Dec 9 05:52:05 PST 2005

On Thursday, December 8, 2005, at 01:28 AM, Ross Boylan wrote:

> When X starts up, it (xorg) consumes all CPU.  The screen is black,
> and the computer is unresponsive to the keyboard (including
> ctl-alt-del, ctl-alt-backspace, ctl-alt-+ or -).  The odd thing is, 
> there
> seem to be no errors of note in the xorg log file or the system logs
> (Open APM does fail).
> There are (II) messages "Not using default mode ... (vrefresh  or hsync
> out of rang)" that seem to cover every possible mode.  But some of the
> same modes appear later like
> (**) NV(0): Default mode "1280x800": 83.5MHz, 49.7 kHz, 60.0 Hz
> with a modeline following.
> Since the FAQ and most other advice I've seen starts with an error
> message, I'm at a loss about how to proceed, and am hoping for some
> advice.
> This is on new hardware with a GeForce 6600 LE chip for video and an
> Intel 945PSN motherboard.  The video uses PCI express (X-press?).
> Mouse and keyboard are pretty standard as far as I can tell. Pentium 4
> 3.0Ghz processor.  Probe reports Video Chipset 0x0142.
> This is a newly installed Debian system (using the etch daily builds,
> which end up installing the "testing" distribution).
> X is 6.8.2.dfsg.1-7
> kernel 2.6.12
> I stepped through the installation questions that Debian provided,
> guessing wildly at the mouse device.  I also added some higher
> resolutions to the default list (consistent with my monitor).
> I am using the nv driver that came with the xorg distro, not nvidia's.
> X works fine under Knoppix 4.0.2.
> Suspicious of my original mouse device choice (it was
> /something/somethingelse/mouse) I tried /dev/psaux, which didn't help.
> I tried removing the mouse completely from the server layout, but the
> log seems to indicate it's being pulled in anyway.
> The last entries in Xorg.0.log are from XINPUT adding the mouse and
> keyboard, warnings the various font renderers are already registered,
> and "Could not init font path element unix/:7100, removing from list!"
> Thanks for any help you can offer.
> Ross Boylan
> _______________________________________________
> xorg mailing list
> xorg at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/xorg

This sound like the problem I was getting installing RHEL 4 on a Dell
Optiplex 620 with an ATI Radeon x600 video card.

The solution was to run


and to run  fglxconfig after the drivers were installed.

More information about the xorg mailing list