problems building from srpm on fedora core 3, not linking libc?

Matt Flaherty matt at
Wed Mar 16 15:47:45 PST 2005


I'm a bit of newbie when it comes to the make build process. For a 
number of reasons I would like to build the xc from a source rpm or from 
source. I upgraded from RHL8 to FC3 on my i386 machine a couple days 
ago. I ran an 'apt-get distro-upgrade' to bring the packages up to date 
with the released-updates repos. There are also some devel and dag 
packages installed. I've manually culled obsolete packages with broken 
dependencies and my system appears to be healthy.

I downloaded xorg-x11-6.8.2-10.src.rpm from one of the fedora mirrors 
and ran `rpmbuild --rebuild -bc --target=i386 
xorg-x11-6.8.2-10.src.rpm`. Make fails at this point:

making all in ./programs...
make[3]: Entering directory 
making all in programs/appres...
make[4]: Entering directory 
gcc -m32 -O2  -pipe -m32 -march=i386 -mtune=pentium4 
-fno-strict-aliasing -pipe -ansi -pedantic -Wall -Wpointer-arith 
-Wundef     -I../.. -I../../exports/include   -Dlinux -D__i386__ 
-D_XOPEN_SOURCE                          -D_BSD_SOURCE 
-D_SVID_SOURCE                           -D_GNU_SOURCE                 
-DFUNCPROTO=15 -DNARROWPROTO       -c -o appres.o appres.c
rm -f appres
gcc -m32 -o appres -O2  -pipe -m32 -march=i386 -mtune=pentium4 
-fno-strict-aliasing -pipe -ansi -pedantic -Wall -Wpointer-arith 
-Wundef     -L../../exports/lib   appres.o -lXt -lSM -lICE -lX11      
../../exports/lib/ undefined reference to `__dlsym'
../../exports/lib/ undefined reference to `__dlclose'
../../exports/lib/ undefined reference to `__dlopen'
collect2: ld returned 1 exit status
make[4]: *** [appres] Error 1
make[4]: Leaving directory 
make[3]: *** [all] Error 2
make[3]: Leaving directory 
make[2]: *** [all] Error 2
make[2]: Leaving directory `/opt01/usr/src/redhat/BUILD/xorg-x11-6.8.2/xc'
make[1]: *** [World] Error 2
make[1]: Leaving directory `/opt01/usr/src/redhat/BUILD/xorg-x11-6.8.2/xc'
make: *** [World] Error 2 

I've attached the tmp file generated by rpmbuild. Searching around has 
got me nowhere. It appears to be failing to link in libc, which I can't 
understand. I've got /usr/lib/libc.a and /usr/lib/ with symbols 
defined for __dlsym, __dlcose and __dlopen. I've tried running the gcc 
line with -lc in front of -lX11 and that didn't help. I'm guessing this 
is because the Makefiles have got 'LD = gcc -m32 -nostdlib', though I'm 
not sure why. I don't have enough experience to know what to do next. 
Any help would be appreciated. Thanks.

gcc = 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)
glibc = 2.3.4
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: rpm-tmp.86560
URL: <>

More information about the xorg mailing list