ATI SurroundView -was- Re: Problem with xv when playing HD videos

Mike Krufky mkrufky at
Thu Sep 22 13:07:43 PDT 2005

Alex Deucher wrote:

>On 9/22/05, Mike Krufky <mkrufky at> wrote:
>>btw, ati surroundview doesn't work AT ALL in linux...  I have not tried
>>the fglrx drivers yet, but I dont think that will make much of a
>>difference, as this has nothing to do with 3d drm. I plan to write this
>>up in a later email with a detailed description.  Nobody seems to know
>>what surroundview is (besides me), so I'll include a full explanation
>>later on.
>Is surround view basically just multi-head using the IGP and the AGP
>card?  If so it should work with xinerama for 2d.  3d across multiple
>cards is not yet supported.

Yes, that's exactly what surroundview is.  When Surroundview is enabled, 
the IGP chipset behaves like a PCI card, so that it can work in tandem 
with the AGP card and provide three (or four) screens.  Right now, I 
have it working only in windows, and not in linux.  I understand 3d 
rendering across multi-head isnt yet supported... This is okay with me, 
as I'm not really into games, although it would be nice to have the 3d 
screensaver working again.

I would like to get all three screens working on this box... This way I 
can test v4l/dvb drivers while watching tv on one screen, look at code 
on the second screen, and have gAIM & thunderbird open on the third. :-D

Here's a link to an error log with surroundview enabled, using X Window 
System Version (7.0.0 RC 0):

That log was from a while ago... Since then I've completely re-built my 
gentoo system, and I'm now using the current beta version of xorg-x11 in 
portage.  I have to turn off surroundview in my BIOS in order to get X 
to work.  It DOES work with surroundview enabled, but only if I delete 
my xorg.conf, forcing it to use the vesa driver instead.

No matter what I do, I cannot even get standard dual-head to work on the 
9600XT.  All that works is clone-mode.  It DOES work in my other box, 
using Radeon 7500... but this is besides the point.

I have an older log somewhere that shows messages from both RADEON(0) 
and RADEON(1) ... but still no luck.

It looks like the memory allocation is wrong somehow.... This could also 
be a quirk with my motherboard:

(WW) ****INVALID IO ALLOCATION**** b: 0xb000 e: 0xb100 correcting
Requesting insufficient memory window!: start: 0xb0000000 end: 0xdfffffff size 0xd4020000

I'm using FT61 motherboard... part of the Shuttle ST61G4 bare-bones system:

I would be very happy to provide any more information that might be needed, in addition to conducting any further testing.
It seems to me that few people are using this SurroundView feature.  Hopefully that will not cause this to be low-priority.
I'd really like to get this working, and I'd be happy to contribute a patch if I only knew where to start.  Unfortunately, something like this is beyond the scope of my device-driver coding experience.

Please, let me know if you have any suggestions.

Thank you.

Michael Krufky

More information about the xorg mailing list