xscreensaver freezes, reboot required

Roland Scheidegger rscheidegger_lists at hispeed.ch
Thu Sep 29 04:01:09 PDT 2005

Jason Cook wrote:
> I do appologize if I'm cross posting here. I'm not sure which forum 
> would be best to address this. I have a encountered an error when 
> running xscreensaver-demo as a normal user. In Slackware 10.2 the
> daemon is not running by default and there is a popup window that
> promts to turn it on. If I click 'okay' then the screen freezes and I
> must reboot. I can't SysRq and I don't have another box to try
> logging into it and shutting it down. If I select 'cancel' then and
> then start the daemon from the menu everthing seems to work fine. No
> lockups. I encounter a similar issue with a dialog box in the game
> S.C.O.U.R.G.E: Heroes of a lesser renoun. Upon starting the actual
> game (once characters are created) I am presented with dialog box.
> The game runs behind this box and I can move the box around the
> screen, but as soon as I close this box then the game continues
> running for maybe 1-2 seconds before the system locks up again. Time
> to reboot.
Not sure, but it could be something which is fixed in xorg cvs (or mesa
cvs). For instance the rasterization fallback was known to cause lockups 
(though I'm still not quite sure why should have been "only" segfault - 
maybe the lock never got released afterwards or something like that).

> I've tried to debug the game with gdb but I get no output before the
>  screen freezes.
Debugging gpu lockups without a 2nd box is a lost cause :-(.

> P.S. By the way is it normal to see visual corruption in glxgears
> when page flipping is turned on? Again I'll post some screenshots if
> it will help.
No, that's not normal (unless you switch to another VT and back, there's 
a bug with that). If the corruption looks like parts are missing (i.e. 
black areas) then that would probably mean stuff is drawn to the wrong 
(i.e. front) buffer. Not sure why that would happen, again it could be 
something which is already fixed, but I'm using pageflip since ages and 
can't remember that it just didn't run at all in a released version 
(that said I rarely use released versions...).


More information about the xorg mailing list