xserver-xorg-video-i810 now only displays 640x480

Alan Chandler alan at chandlerfamily.org.uk
Sat Dec 16 16:01:45 PST 2006

On Saturday 16 December 2006 20:00, David Nusinow wrote:
> On Sat, Dec 16, 2006 at 05:12:51PM +0000, Alan Chandler wrote:
> > I run Debian unstable on an Intel DG965SS motherboard with
> > integrated 965G graphics controller.
> >
> > I have just restarted my computer after having been away for a few
> > days and the display has come up in 640x480 mode and that seems to
> > be the only option.  I have NOT changed xorg.conf so my guess is
> > that a Debian upgrade to xserver-xorg-server-core which according
> > to the changelog took place on 12th December and which probably
> > propagated to my machine just before I shut it down on the 13th to
> > go away is the root cause.
> None of the changes that were made for the last xserver-xorg-core
> update should affect you in this way. You'll have to figure out how
> long it's been since you restarted X and what you updated in that
> time frame. We did an upload of a new version of the i810 driver on
> December 6 which could be the culprit. Could you downgrade to the
> version in testing and let us know if it fixes your problem?

I am aware of the new version of the i810 driver - if you see on earlier 
on this list under the thread "debian package for i810 driver?", I 
reported that I had loaded that new version and it fixed the problem I 
had with video on the 7th December. The loss of video modes was not 
caused by THAT upgrade.

The machine I am refering to is my home desktop and is shutdown during 
the day every day whilst I am at work.  So it would have been shutdown 
during the day of the 13th December and rebooted from scratch that 
evening.  It was probably during then that I upgraded to the new 
version from the debian repository.  I have been away on business on 
the 14th and 15th and got back on the evening of the 15th - when I 
booted up it caused these problems with modes.

I have just tried  to downgrade xserver-xorg-core to 1.1.1-11 by doing a

dpkg -i --force-downgrade xserver-xorg-core_1.1.1-11_i386.deb

(which I manually downloaded) but this did not fix my problem. I assume 
this means that as you said, its not something in the latest version of 

Gabriel C seems to have something - where does that come from?

Alan Chandler

More information about the xorg mailing list