No keyboard

MagicITX magicitx at
Sat Feb 11 08:36:11 PST 2006

This is driving me just a little nuts.  My keyboard doesn't work under
xorg 7.  It works fine in the console.  Once or twice it worked in X
and one time it worked for one keystroke then quit.  There is nothing
in any logs that give a hint of a problem.  Here's the relevant
section of my xorg.conf:

Section "InputDevice"
        Identifier      "Keyboard1"
        Driver  "kbd"
        Option  "CoreKeyboard"
        Option  "XkbRules"      "xorg"
        Option  "XkbModel"      "pc104"
        Option  "XkbLayout"     "latin"
#       Option  "AutoRepeat"    "500 30"

I've tried many configuration.  Here's some of my Xorg.0.log:

(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input/
(II) Module kbd: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.1
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.5
(**) Option "CoreKeyboard"
(**) Keyboard1: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard1: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard1: XkbRules: "xorg"
(**) Option "XkbModel" "pc104"
(**) Keyboard1: XkbModel: "pc104"
(**) Option "XkbLayout" "latin"
(**) Keyboard1: XkbLayout: "latin"
(**) Option "CustomKeycodes" "off"
(**) Keyboard1: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard1" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) Mouse1: ps2EnableDataReporting: succeeded

Any suggestions would be greatly appreciated.



More information about the xorg mailing list