git-rebase nukes multiline comments

Matthias Hopf mhopf at
Fri Jun 16 10:12:51 PDT 2006

Hi all,

I'm using git-1.2.4 on SL10.1, in centralized style development (for

I wanted to commit a set of changes (4 local commits) upstream, so I had
to do a git-rebase first (in that particular case a git-pull would have
been possible as well, but git-rebase fits the CVS style development
better). After git-fetch, git-rebase origin, and git-push all my changes
had only the first line of the changelog comment, the remainder was

To reproduce:

mkdir /var/tmp/blaup
cd /var/tmp/blaup
echo test > foo
git-add foo
git-commit      (any comment)
cd ..
git-clone /var/tmp/blaup bla
cd bla
echo test2 >>foo 
git-commit foo  (multiline comment)
cd ../blaup
echo test3 >bar
git-add bar
git-commit      (any comment)
cd ../bla
git-log         (shows multiline comment for 'test2')
git-rebase origin
git-log         (shows only the first line of the multiline comment!)

I doubt this is intended behavior.

Also, while trying to reproduce this with the original upstream
repository, I would have had to git-fetch my origin branch (upstream
master), but not to get _all_ new commits, but only up to a certain
revspec (the one *before* my own commits).

I tried "git-fetch <refspec>:", but this didn't work, neither did
anything else I tried.  This is clearly beyond my understanding of git,
so how can this be done?



Matthias Hopf <mhopf at>       __        __   __
Maxfeldstr. 5 / 90409 Nuernberg    (_   | |  (_   |__         mat at
Phone +49-911-74053-715            __)  |_|  __)  |__  labs

More information about the xorg mailing list