Xorg 7.1 + Mesa 6.5 + uClibc 0.9.28 + gcc 4.1.1, extensions/libglx.so lockups

Kevin Day thekevinday at gmail.com
Sat Jun 24 09:56:32 PDT 2006

This was originally sent to xorg-modular at lists.x.org, but thanks to
Jerome, I was pointed here, so this contains the original post, his,
and any updates from my tests since then.

> On 6/23/06, Kevin Day <thekevinday at gmail.com> wrote:
> > When I type startx the screen goes blank, and the machine locks up,
> > and must be hard-rebooted.
Doesn't seem to lock up as bad as I had first thought, sometimes the
system is still running so that I can do a soft-reboot.  Only the
monitor/video goes out, and never comes back.  I managed to do this
after recompiling Xorg and removing any possible deviations in Mesa.
> >
> > The /var/log/Xorg.0.log stops having information on the libglx.so
> > module loading.
> >
> > So, to test, I tried gdb, but gdb does not prevent the Xorg from
> > switching the screen mode and the system still locks up, even in
> > stepping mode.
> >
> > I renamed the extensions/libglx.so file to another name so that
> > it would not be found and therefore could not load, and Xorg starts.
> >
> > I cannot figure out where to begin to look for this problem.  Not
> > even a kernel panic has a chance to occur, the entire system locks
> > like that other operating system I need not name.
> >
To get somewhere, I am re-building the system again gcc-3.4.6 to see if
it is gcc-4.1.1 causing the problem.

> > If I can get some steps I need to take to find the problems and deal
> > with this issue.
> >
> > Major files are:
> >   Xorg 7.1 Stuff:
> >    xorg-server 1.1.0:
> >      ./configure --with-mesa-source=$WO/Mesa-Build --enable-dri \
> >      --enable-glx --enable-glx-tls --enable-lbx --disable-fontcache
> > \ --enable-xgl --enable-xglx --enable-xegl --disable-secure-rpc \
> >      --enable-multibuffer --enable-dmx
> >
I don't know what xegl is, but after looking at the linux-dri in detail
from Mesa's source, could that be causing this problem? It is not built
in the Mesa source.

> >    Mesa 6.5:
> >      sed -i 's|lib/modules|lib/X11/modules|' src/glx/x11/dri_glx.c
> >      sed -i 's|lib/modules|lib/X11/modules|' \
> >      src/mesa/drivers/dri/Makefile.template
> >      make linux-dri-x86
> >
I have also tried with "make linux-dri", which also locks-up

> >    Gcc 4.1.1
> >    uClibc 0.9.28
> > --
> > Kevin Day
> Could you provide more information on your configuration,
> like graphics card, ... also try disabling DRI (comment out
> the line about dri in xorg.conf).
Currently Two configurations:
  1) ATI Mobility Radeon 7500 32mb dedicated Video Ram on a Mobile Intel
P4 1.6ghz.
  2) S3 Unichrome Pro 64mb integrated Video Ram on an AMD Athlon64

  On #1, there has probably been some minor hardware damage from moving
around, as it mis-reports its specs to the linux kernel and thus
everysingle thing else.
  For whatever reason it's video card is seem as a 128MB Ati Radeon
7500 card, this card is 4 years old has been 32MB for at least 3 of
those, but At the same time, It's always shown as 128mb on the 2.6

  On #2 there is no problem other than being integrated, and thus using
my system ram instead of dedicated. They both provide the same problem.

  On #1 I am using the radeon driver
  On #2 I am using the via driver

> Also remounting you /var partition with sync option might
> help to get further information in the log.
I will begin to do experiment with that, but for now here is what I
have now.
> Please use xorg at lists.freedesktop.org insted of
> xorg-modular. It's no longuer alive maybe we should kill it.
> It was used during modularisation of Xorg.
> best,
> Jerome Glisse

Attatched is the Xorg.0.log that stops at glx.so and the generic
xorg.conf I use. (Which is then edited by a script to change
REPLACEME_1 to the desired driver, in the case of that log file, the
via driver.)
This particular Xorg.0.log file, came from system #2, but the same
exact stop point exists on system #1.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log
Type: text/x-log
Size: 10518 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20060624/686e38a1/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xorg.conf.basic
Type: application/octet-stream
Size: 10304 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20060624/686e38a1/attachment.obj>

More information about the xorg mailing list