radeon lockup

Erwin Rol mailinglists at erwinrol.com
Wed Jun 28 01:52:45 PDT 2006

On Tue, 2006-06-27 at 09:23 +0200, Michel Dänzer wrote:
> On Tue, 2006-06-27 at 09:13 +0200, Erwin Rol wrote:
> > 

> Looks like the second one wasn't properly POSTed.

The interesting think is I run Xorg 7.0 on a older system with the card
and that still works fine. After yum updating X to Xorg 7.1 and
restarting X it worked, and even better (it directly did 4 heads,
instead of 2x2 clonefb heads, which happened in Xorg 7.0 when a monitor
wasn't connected to the second port). So the card works fine in Xorg

Now after a power cycle i tried to start Xorg 7.1 and it didn't work.
The same problems as on my other machine. Heads 1 & 2 are OK (first M9)
but heads 3&4 have junk (random memory content) on the screen, and as
soon as the second M9 is accessed (like by moving the mouse there) it
hangs the machine hard. 

So it seems the old Xorg 7.0 int10/BIOS stuff could initialize the card,
but the new code can't. 

I will now try to disable the new /sys/bus/pci/.... BIOS read code and
see if it works when the old code does the initialization. Are there any
other big changes that could have to do with BIOS setup since Xorg 7.0 ?

- Erwin

More information about the xorg mailing list