GL, 6.9, and missing TrueColor visuals

timwoj at timwoj at
Wed Jun 28 15:44:52 PDT 2006

On Sat, 24 Jun 2006, Michel Dänzer wrote:

> Date: Sat, 24 Jun 2006 16:52:52 +0200
> From: "Michel [ISO-8859-1] Dänzer" <michel at>
> To: timwoj at
> Cc: xorg at
> Subject: Re: GL, 6.9, and missing TrueColor visuals
> On Thu, 2006-06-22 at 12:49 -0500, timwoj at wrote:
>> I'm having a problem with gl and 6.9.  GL can't seem to find any of
>> the true color visuals that are on the system, but only when I connect
>> from a remote machine.  xdpyinfo says the visuals are there, but
>> glXChooseVisual can't seem to see them.  I have a short snippet of code
>> that can demostrate it.  If I run the code on the local machine, it finds
>> a visual without any problems.
>> I've tested the code on older versions of XF86 as well as a couple of
>> different versions of Xsun, and it works there correctly.  I've also tried
>> this on two separate machines running 6.9 and one running 6.8.2 and
>> it failed on both.
>> If it's something I'm not doing right in my code, I'd rather fix it that
>> way than upgrade to 7.1 if I can.  I've attached the code and the output
>> of xdpyinfo.  The xdpyinfo output was generated by Sun's xdpyinfo on the
>> Solaris box I'm trying to connect from.
> Not sure this is what you're seeing, but I pushed a couple of fixes to
> xserver git for GLX issues when server and client have different byte
> orders.

Updated to 7.1 (after a couple days of screwing with getting it 
built) and got it all started up on this i915 machine, and it still has 
the same problem.  If I remove the GLX_RGBA from the attributes passed to 
glXGetConfig, it finds a visual right with no problems.  But adding that 
in causes it to not find any at all.

The code I built is the latest bits from both CVS and GIT.


More information about the xorg mailing list