Two Radeon Cards, Dell Dimension, Linux and

Thorsten Becker thorsten.becker at
Thu Mar 16 12:22:47 PST 2006

Le Jeudi 16 Mars 2006 16:00, Thorsten Becker a écrit :
> Xorg 7.0.0, kernel 2.6.15-gentoo-r1
> Hello,
> To create a dual seat system I bought a Readeon 7000 PCI card for my Dell
> Dimension 4550, which has a Radeon 9700 already installed. The Problem is:
> I can only get one card to work at a time. Trying to start an X server on
> the "wrong card" results in locking up the system (it doesn't even write an
> Xorg.0.log logfile)
> What I tried so far:
> BIOS settings: The somewhat crippled BIOS in the dell system only has a few
> settings that could be relevant: "Primary Video Controller" is one of them,
> it can be set to AGP or Auto.
> If set to AGP, the AGP card works, the vga console is shown on the Monitor
> that is connected to that card. I can start an X server for that card, and
> it works.
> If set to Auto, the PCI card works, and I can start an X server for that
> card.
> But If it is set to AGP, and I try to start an X server for the PCI card,
> the result is  a complete system lockup, same the other way round.
> I tried to get some useful debugging output by starting X for the "wrong
> card" via ssh and get some information via the -verbose Option. Such a log
> can be found here:
> The xorg.conf can be found here:
> One time a short Xorg log was written. I out it here:
> When I start X whith the -verbose option, the last thing I can see is
> always
> (II) RADEON(0): initializing int10
> (--) RADEON(0): Chipset: "ATI Radeon VE/7000 QY (AGP/PCI)" (ChipID =
> 0x5159) (--) RADEON(0): Linear framebuffer at 0xe0000000
> (--) RADEON(0): VideoRAM: 8192 kByte (64 bit SDR SDRAM)
> (II) RADEON(0): Color tiling enabled by default
> (II) Loading /usr/lib/xorg/modules/
> (II) Module ddc: vendor="X.Org Foundation"
>         compiled for 7.0.0, module version = 1.0.0
> (II) Loading /usr/lib/xorg/modules/
> (II) Module i2c: vendor="X.Org Foundation"
>         compiled for 7.0.0, module version = 1.2.0
> (II) RADEON(0): I2C bus "DDC" initialized.
> and sometimes I see Messages like
> "Requesting insufficient memory window!: start: 0xff800000
> end: 0xff9fffff size 0xff820000"

I tried further things: Booting with an older Gentoo liveCD (containing Xorg 
6.8.2) allows starting an X server on the card that was not selected as the 
one which is selected in bios, while an Ubuntu Live CD shows the same 
behaviour as my installed system.

More information about the xorg mailing list