Font Rendering and Updating the Server Window

Alan James Caruana ajcaruana at
Mon Nov 6 07:22:08 PST 2006


I am trying to compile (using MS VS.NET 2003) and run the version of
XWin that comes with the X11R7.1 release (downloaded from the X.Org
ftp site).

I have managed to compile the server, and it actually runs on windows,
but there are two things that are now working properly.

1. The fonts are not rendering properly.

       When I load the server using the command "XWin :2 -ac -engine 1
-screen 0 @1", I get an empty, idle X Server (GOOD) running on a
Windows Server 2003 with IP  Then I load an xterm from
another machine (running SuSe 9.2) with the command
"DISPLAY= xterm &".  The program runs, but the fonts
are displayed as garbage.

       Also, if instead of opening the server as described above, I
open an XDMCP session to a SOLARIS (I have no idea what desktop
manager runs here) machine, the fonts are also displayed as garbage,
however an XDMCP session to the SuSe 9.2 machine (which runs KDE)
displays the fonts as they should be.

      What could be the problem? I am assuming it has got something to
do with the preprocessor definitions during compilation (All the
problems I had and solved up till now were like that), but what
definition must I add/remove ?

2. The Server Window does not update.

      I start an XDMCP session with the SuSe 9.2 machine (just to have
a session running), and, while the session runs, and everything works,
the server window (in windows) does not update automatically.  For
this to update, I must either minimize the server window, and restore
it, or cover the entire window by another application's window and
then bring the server's window to the front.  Then it will update.

      I am hoping that this problem is just a preprocessor definition
that I missed out during compilation, but I couldn't find anything.  I
also tried changing the rendering engine.  I used ShadowGDI (-engine
1), and also DirectDraw (-engine 2), and DirectDraw4 (-engine 4), but
the result always remained the same. It also does the same thing if I
start an XDMCP session with the SOLARIS machine.

Does anybody have an idea on why I am getting these problems? Any help
would be greatly appreciated.

Many thanks
Alan J. Caruana

More information about the xorg mailing list