xdm: very long pause after login

dark_mail at gmx.net dark_mail at gmx.net
Sun Nov 19 13:46:17 PST 2006

dark_mail at gmx.net wrote:
> dark_mail at gmx.net wrote:
>> Andrew J. Barr wrote:
>>> Just FYI, please use 'Reply to All' to keep the mailing list CC'd. Also,
>>> top posting is considered bad etiqutte by some ML denizens...
>>> On Sun, 2006-11-19 at 16:48 +0100, dark_mail at gmx.net wrote:
>>>> lo is up , and in /etc/hosts I have a line assigning localhost and my
>>>> hostname to
>>>> Btw:
>>>> xdm just respawned when trying to start Xfce, garbling VT1 along with
>>>> it. I just got back to the login screen.
>>> Okay, the next thing to try is X display permissions. I've had issues
>>> where I've changed the hostname of my computer and then the X server
>>> denies connections from clients. If you can get to an X terminal, type
>>> in 'xhost +' and try to start Xfce. That isn't the solution, per se, but
>>> it will tell you that your problem is display permissions if it works.
>>> That's all I've got so if that isn't it someone else will have to try to
>>> help.
>>> HTH,
>>> Andrew
>>>> Andrew J. Barr wrote:
>>>>> On Sun, 2006-11-19 at 16:30 +0100, dark_mail at gmx.net wrote:
>>>>>> As of today xdm stops working after I have logged in.
>>>>>> When using windowmaker, there is a very, very long pause before it
>>>>>> actually starts. Xfce seems not to start at all, but maybe it needs even
>>>>>> longer to start up. During this time, only the mouse cursor is
>>>>>> displayed. CPU load is around zero, there is only a short burst of disk
>>>>>> activity, and the log files don't show anything strange.
>>>>> Sounds like your loopback interface isn't up. Make sure that the 'lo'
>>>>> interface is configured by your bootup scripts and that you have an
>>>>> entry for 'localhost' (and your computer's hostname) in /etc/hosts.
>>>>>> When i log on using the commandline I can start Xfce without any
>>>>>> problems using "startx" or "startxfce4", everything except gkrellm2
>>>>>> works fine (that might be due to runlevel).
>>>>>> Gdm runs like a charm.
>>>>>> I can't recall having changed anything between yesterday (when it
>>>>>> worked) and today regarding X.
>>>>>> I'm using Xfce 4.2 on a Gentoo system, xdm is 1.0.5.
>>>>>> It's not the missing sessreg issue, I had that already, and
>>>>>> XSTATICVT="yes" is set in /etc/conf.d/xdm.
>>>>>> Does anyone have a clue what went wrong?
>>>>>> _______________________________________________
>>>>>> xorg mailing list
>>>>>> xorg at lists.freedesktop.org
>>>>>> http://lists.freedesktop.org/mailman/listinfo/xorg
>> Didn't work.
>> Looks still the same.
>> Thanks, anyway, for helping, and I'll consider your advice :-)
>> _______________________________________________
>> xorg mailing list
>> xorg at lists.freedesktop.org
>> http://lists.freedesktop.org/mailman/listinfo/xorg
> OK, Xfce finally started from xdm after an eternity, but still gkrellm2
> won't show up.
> Apart from that everything seems normal.
> _______________________________________________
> xorg mailing list
> xorg at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/xorg
Finally got it:
Xservers was somehow missing a :0
It was
:0 local /usr/bin/X vt7
instead of
:0 local /usr/bin/X :0 vt7

For all of those who might run into similar problems ...
(gkrellm still not working, but that's minor)

More information about the xorg mailing list