i810 1.7.4 driver lockups

Thomas Hellström thomas at tungstengraphics.com
Thu Feb 1 15:18:21 PST 2007

Roderick Greening wrote:

> Ok,
> I build the latest from git, removed the file as indicated. Copied the 
> *.ko files to proper lib dir.
> Rebuild libdrm and x11-drm packages.
> Now, system boots and the new modules seem to be loading. glxgears 
> works with a 50% increase in fps.
> Now, I try to run some 3D accellerated apps and I get visual 
> corruption. Tried Neverwinter Nights (native game) and then I tried 
> some games via Wine (which previously worked - opengl based like Jedi 
> Outcast). All received with some form of corruption/crash.
> Do I need to rebuild any other parts of X/Mesa or the xf86-video-i810 
> or should I just wait until a newer kernel and X packages are published?

Please report corruption / bugs on the mesa bugzilla. The i915tex driver 
is still quite new and may have some glitches.

For critical needs you can always revert back to the old driver using 
the "Legacy3D" option that Alan mentioned.


More information about the xorg mailing list