Poor image quality on Thinkpad T60 notebook WXSGA+ w/ Intel Corporation Mobile 945GM

Gregory Maxwell gmaxwell at gmail.com
Mon Feb 5 22:39:41 PST 2007

On 2/6/07, Keith Packard <keithp at keithp.com> wrote:
> You can try the modesetting branch of the intel driver; that will dump
> out all of the relevant register contents to the log file so we can make
> sure the hardware is programmed correctly. It's also possible that it
> will program the hardware differently than the BIOS.

Sure thing! Good thing Fedora packages the modesetting driver too..
this was a snap.

I tried it. X starts up but it is apparently totally unaware that it
is giving me a useless black screen.

Sounds like https://bugs.freedesktop.org/show_bug.cgi?id=6942 perhaps?
   As a WAG I tried using the driver option to disable DDC, but it
didn't help. (nor did it appear to do much of anything).

This is the output of the modesetting driver:

For reference, this is the output of the normal driver:  (which works,
but I'm hoping it's the cause of my 16bit output rather than my

All of this output is after a fresh power cycle.. but earlier I played
with the 915resolution tool and I noticed that it's idea of the bios
differed from the i810 driver's (the url directly above):

(look at mode 6c vs i810 drivers idea of 6c.. weird?)

And for completeness sake, my xorg.conf:

It's really boring.. to switch to the modesetting driver I just change
the driver line to "intel" ... The fedora folks are nice enough to
package both. (and I guess on some hardware they auto switch to the
modesetting driver)

Thanks for the suggestion, if you think I should log my output into
any particular bug, please let me know. Obviously, if there is any
other data you'd like me to collect...

More information about the xorg mailing list