Latest i810 driver

Eric Anholt eric at
Tue Feb 6 14:46:17 PST 2007

On Tue, 2007-02-06 at 23:28 +0100, Lukas Hejtmanek wrote:
> On Tue, Feb 06, 2007 at 05:31:57PM +0000, Keith Whitwell wrote:
> > I'm just coming into this, but it seems like the i810 driver is getting 
> > confused between new (ie ttm) and legacy drivers - you are being 
> > directed to use the legacy driver, but the memory looks like its being 
> > set up for the ttm driver.
> > 
> > The ttm driver allocates its own memory for textures and doesn't use the 
> > fixed region set up by the i810 driver.
> > 
> > I'm cc'ing Thomas in case he has an idea about a fix.
> It looks like there is different problem. I've tried latest agp and drm:
> Linux agpgart interface v0.102 (c) Dave Jones
> [drm] Initialized drm 1.1.0 20060810
> ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 16
> PCI: Setting latency timer of device 0000:00:02.0 to 64
> [drm] Initialized i915 1.8.0 20060929 on minor 0
> But in Xorg log I got:
> (II) I810(0): MakeTiles failed for the front buffer
> (II) I810(0): Activating tiled memory for the back buffer.
> (II) I810(0): Activating tiled memory for the depth buffer.
> (II) I810(0): RandR enabled, ignore the following RandR disabled message.
> (WW) I810(0): Option "VideoRAM" is not used

Looks like you tried to do
Option "VideoRam" "number"
instead of
VideoRam number

It's still a bug if you need VideoRam at all, but at least that should
help you work around it for now.

> (EE) I810(0): Too little AGP aperture space for DRM memory manager.
>         Please increase AGP aperture size from BIOS configuration screen
>         or decrease the amount of video RAM using option "VideoRam".
>         Disabling DRI.
> (II) I810(0): [drm] removed 1 reserved context for kernel
> (II) I810(0): [drm] unmapping 8192 bytes of SAREA 0xef885000 at 0xb7bec000
> (--) RandR disabled

Eric Anholt                             anholt at
eric at                         eric.anholt at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the xorg mailing list