<mod> shift <key> != shift <mod> <key>

Glynn Clements glynn at gclements.plus.com
Sun Feb 18 15:14:40 PST 2007

Mia Via wrote:

> I think this started when I upgraded to FC5 and whatever xorg update
> came with it.
> I type a lot of ctl-shift-<key> and alt-shift-<key> combinations to
> both my shell (zsh) and my editor (xemacs).
> The order of pressing and holding down the modifier and the shift
> keys didn't use to matter, i.e. I could press and hold down the ctrl
> key, then the shift key, then press the <key> I wanted or I could
> press and down the shift key first, then the ctrl key, then the key,
> and would get the same result. Not that I consciously add to think
> about which to press first, it would be up to my fingers.
> With current versions of xorg I get different results depending on
> the order of holding down the shift and the extra modifier, with
> annoying results, e.g. ctrl-shift-underscore is undo but
> shift-ctrl-underscore gives me an underscore.

I suspect that if you run "xmodmap -pk", you will see that 109 (the
right-hand control key) is mapped to something like:

    109    	0xffe4 (Control_R)	0xff20 (Multi_key)	

IOW, pressing the right-hand Ctrl key with either Shift key held will
generate something other than Control_R (in my case, it was Multi_key,
aka "Compose").

> Is there a way to disable this and get the old behavior back?

I fixed it by adding the following to ~/.Xmodmap:

	keysym Control_R = Control_R

Glynn Clements <glynn at gclements.plus.com>

More information about the xorg mailing list