Xorg Modular build on FreeBSD 7.0

Vincent Blondel vincent at xtra-net.org
Mon Jul 23 11:11:06 PDT 2007

On Sun, July 22, 2007 10:38, Vincent Blondel wrote:


Can somebody help me compiling xorg (git version) on FreeBSD-current (7.0).

I downloaded last git xorg version (20070721) and last version from Mesa
(7.0). I extracted Mesa sources as mentionned on their site but I got some
problems by downloading xorg git version.

First of all I had to replace /bin/sh with /bin/bash because /bin/bash is
not really fully compliant with FreeBSD Bourne Shell.

Secondly, I had to download pixman manually because pixman is not located
at git://anongit.freedesktop.org/git/xorg/pixman but
git://anongit.freedesktop.org/git/pixman and I placed this directory at
the same level of app ... xserver.

Once these problems resolved , I ran the compilation phase but lots of
things do not compile like

***** install failed on lib/libXcomposite
***** install failed on lib/libXtst
***** install failed on app/rendercheck
***** install failed on app/xdriinfo
***** install failed on xserver/

This is the way I compile xorg git repository.

PKG_CONFIG_PATH=/opt/X11R6/lib/pkgconfig ACLOCAL="aclocal -I
/usr/local/gnu-autotools/share/aclocal-1.10 -I /usr/local/share/aclocal
-I /opt/X11R6/share/aclocal"
./util/modular/build.sh -m /tmp/Mesa-7.0 -n -D /opt/X11R6

So has somebody already succesfully compiled xorg git version on FreeBSD ?
Thanks to help me.

Forgot to say you can find log of the build at

Thanks to help me because I really get a problem with my ATI Radeon
Adapter and I would like to see if the problem is solved with the last
xorg version.


More information about the xorg mailing list