Xorg Modular build on FreeBSD 7.0

Vincent Blondel vincent at xtra-net.org
Tue Jul 24 01:30:39 PDT 2007


I made a global answer to you. I hope my problem is more clear now ??
Thanks for your help :-)

Vincent Blondel wrote:
> Secondly, I had to download pixman manually because pixman is not located
> at git://anongit.freedesktop.org/git/xorg/pixman but
> git://anongit.freedesktop.org/git/pixman

I fixed that yesterday, so the git_xorg.sh script should pull the right
one now.

thanks :-)

It would be nice to change /bin/sh with /bin/bash. This would be clear for
BSD people that maybe not know that /bin/sh is most of the time just a
symbolic link to /bin/bash on Linux systems. Furthermore, it is in this
case incompatible with native /bin/sh on FreeBSD platforms but this is not
my current problem and I give you this little warning just for info.

> Once these problems resolved , I ran the compilation phase but lots of
> things do not compile like
> ***** install failed on lib/libXcomposite
> ***** install failed on lib/libXtst
both cases just man pages missing. you'll be fine without them.

> ***** install failed on app/rendercheck
I guess that's caused by a wrong automake version. not sure about that

I run ports gnu-autoconf and gnu-automake that respectively use autoconf
2.61 automake 1.10

> ***** install failed on app/xdriinfo
missing mesa. did you make install it?

> ***** install failed on xserver/
missing pixman. did you make install it?

Not at all I just got the pixman directory and put it on the same level as
xserver. After a little look on the developers page, maybe should I
compile the package in /opt/X11R6 ( same place as the one I use for git
version of X11R6 ). It seems we get two possibilities to compile Mesa x86
or dri but I do not know which one I have to use ?

 make linux-x86 ( freebsd-x86 if that exists ?? )
 make linux-dri ( freebsd-dri if that exists ?? )

Is it possible to put all of them in /opt/X11R6 ( pixman and Mesa ) so I
do not impact my local xorg package version ?

> I downloaded last git xorg version (20070721) and last version from Mesa
> (7.0).

You'll need the mesa GIT master branch to build xserver master for now.

I will make a git clone git://anongit.freedesktop.org/git/mesa/mesa

> ***** install failed on lib/libXcomposite

WARNING: configure did not find xmlto, cannot create Xcomposite.man
without it
sed -e 's|"__vendorversion__"|"libXcomposite 0.4.0" "X Version 11"|'  -e
's|__xorgversion__|"libXcomposite 0.4.0" "X Version 11"|'  -e
's|__xservername__|Xorg|g'  -e 's|__xconfigfile__|xorg.conf|g'  -e
's|__projectroot__|/opt/X11R6|g'  -e 's|__apploaddir__||'  -e
's|__appmansuffix__|1|g'  -e 's|__libmansuffix__|3|g'  -e
's|__adminmansuffix__|8|g'  -e 's|__miscmansuffix__|7|g'  -e
's|__filemansuffix__|5|g' < Xcomposite.man > Xcomposite.3
cannot open Xcomposite.man: No such file or directory
*** Error code 2

> ***** install failed on lib/libXtst

Related to manpages as well, could be the same problem as above.

> ***** install failed on app/rendercheck

./configure: line 3360: syntax error near unexpected token `RC,'
./configure: line 3360: `PKG_CHECK_MODULES(RC, xrender,'
*** Error code 2

Might need fixing for automake 1.10 or something.

> ***** install failed on app/xdriinfo

checking for library containing glXGetProcAddressARB... no
configure: error: cannot find GL library - make sure Mesa or other OpenGL
package is installed
See `config.log' for more details.

> ***** install failed on xserver/

checking for XSERVERCFLAGS... configure: error: Package requirements
(randrproto >= 1.2 renderproto fixesproto >= 4.0 damageproto >= 1.1
xcmiscproto xextproto xproto >= 7.0.9 xtrans scrnsaverproto >= 1.1
bigreqsproto resourceproto fontsproto inputproto >= 1.4.2 kbproto >= 1.0.3
dbus-1 videoproto compositeproto >= 0.4 trapproto recordproto
resourceproto xineramaproto evieproto xkbfile xfont xau fontenc pixman >=
0.9.2 dbus-1 xdmcp) were not met:

No package 'pixman' found

> Thanks to help me because I really get a problem with my ATI Radeon
> Adapter

What kind of problem?

I posted a message in the month of June explaining the problem I encounter
( http://lists.freedesktop.org/archives/xorg/2007-June/025634.html ) so
due the fact it does not work at the moment I returned to previous version
Xorg 6.9. This one does not give me any problem.

> and I would like to see if the problem is solved with the last xorg
> version.

Can't you build just xf86-video-ati or mesa first?

I am really interested with last version of Xorg because I would like to
try apps as Beryl and/or Compiz that sould give me nice effects on my
Gnome system.


More information about the xorg mailing list