[i810-1.7.4] Spurious crash on resume

Gautam Iyer gautam at math.stanford.edu
Sun Jul 29 09:16:17 PDT 2007

On Sun, Jul 29, 2007 at 01:03:06AM +0200, Raúl Sánchez Siles wrote:

> > I noticed that after upgrading my kernel from 2.6.19 to 2.6.21, I get a
> > seemingly "random" crash when I resume my laptop (after suspending to
> > ram). Most of the time, my laptop resumes OK. However once in a way, I
> > get a complete freeze.
> > 
> > Everything works fine when I use Kernel 2.6.19-r5 (gentoo). I get the
> > seemingly random crash when I use Kernel 2.6.21-r4 (gentoo). Would any
> > one know what's going on?
> You forgot to mention your laptop model. That information is valuable.

Sorry. I got a Linux Certified laptop (LC2210E).

> Also are you sure you haven't upgraded i810 Xorg driver as well?

Yes, certainly. My system logs show that I've been using i810-1.7.4,
since Jan 15th, 2007. (Plus I reverted back to the 2.6.19 kernel, just
to ensure that the only change in my system was the Kernel. When I
reverted, I got no problem...)

> According to your explanation and your log this seems a BIOS related
> problem. The driver stops working when it invokes int10 (BIOS)
> sometimes, possibly because the kernel is doing some new optimisation
> which is giving you a problem. I advice you to look at acpi4linux and
> investigate there.

Great, thanks. I'll look into it.

> Is the crash a total (machine) freeze, like not pingable I guess not
> from your explanation.

I can certainly say that some crashes I've had have not been total. I
bound my power button to hibernate to disk (using acpid). When I get the
above freeze, I hibernate to disk, and then resume. When I resume I see
a few numbers on the VT X was running on. I restart X, and I'm fine :).

However on some crashes the above does not work. It could be because
hibernate thinks it's sill running, and refuses to suspend again. Sadly
I never had another computer to plug in and test what I could do over
the network.

> In this case is the video POST method used that fails. Test vbetools
> with are quite well integrated in the hibernate scripts.

Strange. When I use vbetools with hibernate scripts, I get bad results.
It only works on my system if I suspend to ram while running X (without
switching to a dummy VT), and let the i810-1.7.4 driver handle waking up
the video...

> One last comment: maybe you could try the latest Xorg Intel 2.1 driver

Ah! I should have probably tried before posting. The 2.0 driver gave me
trouble a while back (crashed every time I tried to resize the screen).
Someone on the Gentoo forums said I might be OK if I upgraded to the
testing version of the xserver too. But I wimped out ... :)

Thanks for the info (and response)!


"Meesa Jar Jar Binks of Borg! Yousa gonna be Assim'lated!"

More information about the xorg mailing list