Losing X Fonts

Alan J. Greenberger alanjg at ptd.net
Tue Nov 13 06:10:02 PST 2007

I posted the following query to gmane.linux.debian.user group but
received no response.  I have lost the X fonts twice since then.  So I
thought I would try again in xorg at lists.freedesktop.org .

(Originally Posted on October 17):
I am having a problem where the X server is intermittently losing most
of its fonts.  I started seeing this problem a month or so ago.

The X server is running on an etch machine logging in to a sarge
machine.  Both machines have xfs daemon running.  The font path is set
All of a sudden after a number of days, most of the fonts disappear.
xlsfonts shows only 24:
11 more
11 more
which, for what it's worth, correspond to the contents of
/etc/X11/Speedo/xfonts-scalable.scale on the sarge machine.

When this happens, I have tried the xset command with fp= or fp rehash
with no effect.  The only thing that fixes it is to log off and log back
in.  After that it is back with all its fonts.  Note that the xfs
processes on both machines and the X process on the etch machine
continue to run through this re-login.

I don't see anything unusual in /var/log/Xorg.0.log or
~/.xsession-errors .  Nine days ago, I noticed that I was running xorg
7.1.0-16 and there was a 7.1.0-19 available, so I upgraded.  I thought
this had fixed it, but it happened again today.

Any ideas?

More information about the xorg mailing list