Testing latest Intel driver ...

Daniel Kasak dkasak at nusconsulting.com.au
Tue Nov 13 17:12:50 PST 2007

Hi all.

I've done some testing with the latest Intel driver ( today's git ),
against xserver-1.4 and mesa-7.0.2. I have an i845G chip.

Firstly, the success story. Compiz now runs with exa enabled :) It used
to lock X, and I had to ssh in and reboot. Having said that, it's not
really usable, because it's g-l-a-c-i-a-l-l-y slow. I understand that
this is being worked on. Fair enough.

So, switching back to xaa ( which I had to manually specify, as it now
defaults to exa ), one show-stopper pops up. Windows aren't being
updated. Often when a window is initially created, it will appear black.
Resizing it a couple of times will make it render properly. And then
later on, when the contents of the window should have changed, it
doesn't update. Resizing it a couple more times fixes it again. This is
OK for most windows, but dialog boxes in particular, that have been told
not to allow resizing, are unusable.

Now, some points of confusion. In /usr/lib/dri, I've got:

-rwxr-xr-x 1 root root 2157656 Nov 13 11:24 i810_dri.so
-rwxr-xr-x 1 root root 2264440 Nov 13 11:24 i915_dri.so
-rwxr-xr-x 1 root root 2268888 Nov 13 11:24 i915tex_dri.so
-rwxr-xr-x 1 root root 2342744 Nov 13 11:24 i965_dri.so

And my X log says it's loading the i915_dri.so driver:

(II) AIGLX: Loaded and initialized /usr/lib/dri/i915_dri.so

But I thought that the i915 driver had been dropped in favour of the
i915tex driver. The Legacy3D option has been removed:

(WW) intel(0): Option "Legacy3D" is not used

Anyway, I tried moving the old i915 driver out of the way and renaming
the i915tex driver, and this caused a kernel oops, so I moved things
back. I can retest and get the details of the oops if you like.

Also, the man page for the driver still notes the Legacy3D option - this
should be removed.

Lastly, since I *appear* to be using the old i915 driver, I assume I'm
*not* using zero-copy-tfp? Perhaps I'd see better performance if the
i915tex driver didn't oops? Just curious. This setup is on the verge of
being usable by my workmates, but not *quite* yet ...

Full X log attached if people are interested.


Daniel Kasak
IT Developer
NUS Consulting Group
Level 5, 77 Pacific Highway
North Sydney, NSW, Australia 2060
T: (+61) 2 9922-7676 / F: (+61) 2 9922 7989
email: dkasak at nusconsulting.com.au
website: http://www.nusconsulting.com.au
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log
Type: text/x-log
Size: 35534 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20071114/83f96f2c/attachment.bin>

More information about the xorg mailing list