xrandr doesn't unclone CRTCs...

Matthias Hopf mhopf at suse.de
Tue Nov 20 03:52:47 PST 2007

On Nov 20, 07 10:24:23 +0100, Maarten Maathuis wrote:
> I bisected it to commit: 307f3686d3d517cb29b8e66d8ad2ff76a48748b7
> It's not immediatly obvious what the problem is. I will try some things later.

Hm. I understand that previously it used the simple case ("First try to
match up newly enabled outputs with spare crtcs"), but that was actually
wrong, because your case isn't a simple case (there is no spare crtc
available). In your case it worked, but in others it doesn't.

Apparently, the pick_crtcs_score is doing something wrong. Or you're
stumbling over that bug in base RandR that I fixed in the Xserver at
about the same time. I've hit that bug twice in the meantime (and both
times I had forgotten that I already fixed it).



Matthias Hopf <mhopf at suse.de>      __        __   __
Maxfeldstr. 5 / 90409 Nuernberg   (_   | |  (_   |__          mat at mshopf.de
Phone +49-911-74053-715           __)  |_|  __)  |__  R & D   www.mshopf.de

More information about the xorg mailing list