Some questions about xf86-video-intel driver

Simon Pasch fpasch at
Fri Oct 19 07:37:18 PDT 2007

Hello list!

I have some problems with the intel driver in xorg. The memory usage
of a self compiled X is nearly 260MB. With the vesa-driver it only
needs some Megs.

My Hardware Configuration:
intel 945gm

I used:
xorg-server 1.4
x86-video-intel 2.1.1
(Tried to use Mesa 7.0.1, libdrm 2.3.0, too)

I only need 2D...

After a week of trying I'm stuck now...

My questions are: (please keep in mind, that I'm a X-newbie...)
- Am I right, that the Intel driver needs DRI for accelerated 2D, too?
(is the missing DRI-usage possibly the reason, why X reserves so much

- Do I need Mesa, if I only want to use 2D? Do I need Mesa to get DRI working?

-The Kernel apggart driver reports that the AGP aperture size is
256MB. Is this possibly the reason, why X eats all the mem? (don't
have a BIOS option to lower the AGP aperture size)

-What do I have to do, that the intel-driver uses the kernel-drm?
(currently it makes no difference, if the i915-module is loaded or

-Do I use the right combination of program-versions?

-Do you have an idea, what's the reason for the huge memory-allocation?
I tried to lower the VideoRam by defining it in xorg.conf, but the
driver reported:

(WW) intel(0): VideoRam configuration found, which is no longer recommended.
(II) intel(0): Continuing with default 262144kB VideoRam instead of 8192 kB.

I'm thankful for any hint...


More information about the xorg mailing list